Posts by Esheon

Nitrado now has an official Discord server to bring communities, friends and other gamers together!
Join the Nitrado Community Discord now and share your experiences and knowledge with others!

Click here to go to the Discord Server!

    3 of the 4 servers I manage seem to be down. All four are hosted in New York.


    On the Gameserver page they just have " - " in the "Players" column, where the one working server actually shows " 3/32 ".


    Restarts didn't fix it, nor did restoring a backup on one of the servers. I'm putting in a ticket now.

    Just to clarify, DOAGEN ...

    On the Dashboard page underneath the "Restart ATLAS" button, I see


    Atlas Settings

    Mapname:

    Blackwood

    Servername:

    ********

    Server Password:

    ********

    1x1 Map selected

    Currently a 1x1 map is selected. This map does not support grid functions. Grid options disabled.

    Save Button


    I'm assuming we should enter the password into the Server Password box in this section. Seems a safe assumption in any case. When I set it up, The server is active and shows the correct name, but does not require any password at all. I think the issue is that the ATLAS password is stored in the servergrid.json file for a normal ATLAS map created through the server grid editor, while Blackwood maps seem to require a command line argument for the password, i.e. "start ShooterGameServer.exe Blackwood?ServerPassword=XXX?ServerAdminPassword=XXX?MaxPlayers=20?ReservedPlayerSlots=0?QueryPort=*****?Port=*****? -log -server -NoSeamlessServer". Unfortunately, we can't access the command line directly. Putting the password into GameUserSettings.ini (like you would for ARK) doesn't work either. Hopefully they'll get this resolved soon.


    Is there a way to enable the -exclusivejoin option? I can't find the setting anywhere on the Nitrado web interface, but I know it can be done in ATLAS.

    I am unsure if this will work, as I do not play on console. If you have access to the full Game.ini file in Expert Mode, it should theoretically work. I would do a backup/game save before trying it just in case.


    That being said, there is a solid method of reducing harvesting lag on PC servers that has worked well on the 3 I manage.


    First, set the normal HarvestAmountMultiplier to 1.


    For EACH harvestable resource, input a separate HarvestResourceItemAmountClassMultipliers= line into the Game.ini. An example follows:


    Code
    1. HarvestResourceItemAmountClassMultipliers=(ClassName="PrimalItemResource_Thatch_C",Multiplier=10.0)

    If you go on YouTube and search for "MistrFister Harvesting Lag", you should find a video that goes into more detail with the full code for all base items. If there are Prim+ items that don't exist on regular ARK, you would have to find the item class name and make lines for those as well.


    On my Valguero server, i had a Doed that was causing a lag spike with every tail swing. Doing this eliminated it. A friend manages another server with a 50x harvesting rate and they use the same code.

    It doesn't matter whether you're using Expert Settings.


    If you want them to be able to restart your server or change server settings...

    Log in on nitrado.net

    Click your name at the top, then click "My Services"

    Under the server you want to give them access to, click the arrow pointing down ( v ), then click "Edit Guest Access Rights".

    Put their Nitrado account name in the box and click "Add User".

    They must create a Nitrado Account before you can do this.


    If you want them to be an admin on the server, just put their Steam ID in the Admin box on the General page in the server settings. (Or just give them the Admin password... but the Steam ID method is better).