Posts by erroratseeek

Nitrado now has an official Discord server to bring communities, friends and other gamers together!
Join the Nitrado Community Discord now and share your experiences and knowledge with others!

Click here to go to the Discord Server!

    Seems there is a workaround for everything:

    I sat in front of my macbook till 1:00am trying to start my server with no luck. Starting or stopping resulted in loops which had to be forced to stop.

    This morning I checked my server and it was running again. In the logs I saw it restarted at 4:00am wich is an automated task within the webUI.

    I changed again some code and again... stopping (and starting) the server ended in a loop. so I forced a stop and created a new automated task to start it in 5 minutes and tadaaaa. server starts without problems. after a couple of minutes I triggered a stop via the webUI buttons and again loops.

    So I guess nitrados webUI is buggy or just underpowered on server / network capacities.

    If they would care... I reported that issue a couple of times in the past but in the time it takes them to response the server worked again and so there is nothing to investigate from their point of perspective. Also they claimed not to have any further access to logs that we have. So if I can't see the issue in the logs, they can't too.

    Got tired of this after months.

    Maybe the problem is on nitrado's side....

    Half an hour after writing my last post I had a server restart and since then the server is unable to start properly.

    It hangs in "Server wird gestartet..." and I have to force a shutdown after a couple of minutes. Even after reinstalling the original xml-files the server won't boot.

    One time the UI said that the server is started but it doesn't appear in-game.

    Sometimes even the Web-UI won't reload anymore and I get http 50x errors...


    Had that last year for weeks. Every couple of days the server didn't restart for hours; because of that I stopped renting a server and playing the game.

    That's a really messedup... just spend about 60+ hours in base-building.

    Thank you for that tip, must overheard that. For me the "-1" did also cause to just spawn 1 instead of i.e. 100 items. Also it seems that the rotation of the item is randomized then.


    I found another solution or either a workaround:


    # Step 1

    I switched the software I used to use for up and downloads. Till yesterday I used Filezilla for macOS which gave me complaints about Nitrado's TLS-encryption chain. Now I use a Visual Studio Code Expansion called ftp-simple so I can upload directly from my editor instead of using two programs.


    # Step 2

    When I want to change a custom event and it's related entries, I now out-comment all my customized code for that area (actual electro hospital) start the server and log in for a couple of seconds to forcing the server to reload that area. When I checked the spots and they are empty I move away about 50m logout, stop the server and redo the out-comment.


    # Step 3

    When I start the server again and log in seconds after restart most items spawned or pop up while I run to their spots.

    I guess uploading the "cleared" code is necessary the last days I hat a 100% success-rate spawning all my items in the amount and rotation I specified.

    When I just add an event/item-spawn near the other stuff it won't spawn.

    btw. I use <saferadius>0</saferadius>, <distanceradius>0</distanceradius> and <cleanupradius>0</cleanupradius>



    Hey there just got a new server with 1.15 after taking some time off in the 1.11ish times.

    I used to spawn Logs, Piles of Planks and other resources near my base building sites which went quite well in 1.08-1.11.

    I startet out at Vybor in the first week and reused my code to spawn the resources but the stuff never spawned. Then I moved to airfield and tried building there but the same thing here.

    So I tried some of Scalespeeders Tutorials and using his code to spawn stuff but it worked just 1 of 10 times. BTW I saw now obvious changes to the practise in older versions

    For example I place 10 different events/items each 5m away from the next one but just one spawns.

    I tried to add the code at the bottom of the files just before the last self-closing elements, like I did in the old times and also tried to add it at the top just before the first elements; The not seem to care... nothing works constantly...


    Any Ideas?

    YES I shut down the server, wait about 5 minutes, upload my files and wait again a couple of minutes before I turn the server on again and YES I do check the code for errors and just upload valid and wellformed code.


    ***

    Hallo zusammen. Habe einen neuen 1.15er Server nach dem ich eine Weile weg von DayZ war in den Zeiten von 1.11.

    Normalerweise habe ich Stämme, Bretter und andere Ressourcen neben meiner Base-Baustelle gespawnt bei 1.08-1.11 auch immer geklappt hat.

    Ich startete in Vybor und benutzte meinen alten Code aber selbst nach ein paar Tagen spawnte nichts. Dann bin ich zum Airfield umgezogen und habe es erneut probiert ohne Erfolg.

    Ich habe dann ein paar Tutorials geschaut von Scalespeeder, ich verwende auch teile seines Codes die einwandfrei klappen, aber die Spawns klappen vielleicht bei 1 von 10 Versuchen. Nebenbei habe ich auch keine Änderungen in der Praxis bemerkt im Vergleich zu den alten Versionen.

    Als Beispiel: Ich platziere 10 Events/Gegenstände mit je 5m Abstand zu einander aber nur eins der Items spawnt tatsächlich.

    Ich habe den Code am Ende vor den Sich-selbst-schließenden Elementen platziert was früher immer geklappt hat. Habe es diesmal auch am Anfang also vor dem ersten Element versucht.


    Irgendwelche Ideen?

    JA ich fahre den Server 5 Minuten vor dem Upload runter und schalte ihn erst mehrere Minuten später an und JA ich lade nur fehlerfreien validen und wohlgeformten code hoch.

    ***


    An example of code *** Codebeispiel

    <!-- code in cfgeventspawns.xml -->

    <event name="StaticBarbedWireEL">
    <pos x="10292.000000" z="2264.000000" a="1" />
    </event>

    <!-- code in events.xml -->

    <event name="StaticBarbedWireEL">
    <nominal>100</nominal>
    <min>100</min>
    <max>100</max>
    <lifetime>300</lifetime>
    <restock>0</restock> <!-- Normally I used 1 instead of 0 so I get infinite items but since 1.15 no custom item spawned when restock was active *** Hier hatte ich sonst immer eine 1 statt einer 0 um unendlich viele items zu bekommen aber seit 1.15 scheinen nur noch custom-events mit einem 0er-Restock zu spawnen -->
    <saferadius>0</saferadius>
    <distanceradius>0</distanceradius>
    <cleanupradius>0</cleanupradius>
    <flags deletable="0" init_random="0" remove_damaged="1"/>
    <position>fixed</position>
    <limit>mixed</limit>
    <active>1</active>
    <children>
    <child lootmax="0" lootmin="0" max="100" min="100" type="BarbedWire"/>
    </children>
    </event>

    I thought for month my green ada was buggy because there where nothing in the trunk but i sometimes realized that there was bug that prevented the trunk-content-window to open.

    By the way lifetime 2seconds is kinda low for my experience. I keep each car 44 days if it wont get ruined. your cars will despawn if you wont interact with them for 2 seconds after your first ride. no matter how long or short the ride is.

    Just wait a couple of hours. Myself and some others have the same issue; Servers that worked stable for weeks starting to crash constantly. Sometimes after minutes sometimes when you try to connect in-game.


    Try to stop the server for a couple of hours to avoid damage to your databases and check if your powered of server is still shown in the game lobby. That happens to me very often. I guess that is related to network traffic and nitrados network performance.


    Hope this helps

    hi 1 is okay for 1.0 tested it a while ago as I read it somewhere. I wanted to reduce signs for keeping filesize == RAM down.

    I guess you have to wait till all old cars on the map despawned. you could set lifetime to 3 for all cars and restart the server. after an hour change back to your value and restart.

    Mentioned this more detailed a few times in other posts.


    Think about spawning base buildiung materials or sets of weapons and clothes in cars. I had a while ago all olgas filed with different sets of materials, adas with different set of personal gear for me and my friends.

    Hi thanks for answering. About 3 hours after my post the server stopped crashing an I played a bit everything smooth. If the error isn't on our side I would guess that this issues are performance related to nitrados infrastructure. For me it looks like there is to many traffic when many people are playing which causes the nitrado network to break down. like an ddos-attack. I remember when DayZ came to Gamepass. My Server was so full I can't connect and was in queue. Before Gamepass my server was the only one with Q at the names beging in EU and suddenly there where dozens. in this time my server crashed much more often.

    Below the code for my Olga. For the damage you have to change the damage tag

    in example <damage min="0.00" max="0.00" /> every item below that tag will be affected.

    With this example top on the cfgspawnabletypes.xml any item will spawn pristine.


    <type name="CivilianSedan">

    <attachments chance="1">

    <item name="CivSedanWheel" chance="1" />

    </attachments>

    <attachments chance="1">

    <item name="CivSedanWheel" chance="1" />

    </attachments>

    <attachments chance="1">

    <item name="CivSedanWheel" chance="1" />

    </attachments>

    <attachments chance="1">

    <item name="CivSedanWheel" chance="1" />

    </attachments>

    <attachments chance="1">

    <item name="CarRadiator" chance="1" />

    </attachments>

    <attachments chance="1">

    <item name="CarBattery" chance="1" />

    </attachments>

    <attachments chance="1">

    <item name="SparkPlug" chance="1" />

    </attachments>

    <attachments chance="1">

    <item name="HeadlightH7" chance="1" />

    </attachments>

    <attachments chance="1">

    <item name="HeadlightH7" chance="1" />

    </attachments>

    <attachments chance="1">

    <item name="CivSedanDoors_Driver" chance="1" />

    </attachments>

    <attachments chance="1">

    <item name="CivSedanDoors_CoDriver" chance="1" />

    </attachments>

    <attachments chance="1">

    <item name="CivSedanDoors_BackLeft" chance="1" />

    </attachments>

    <attachments chance="1">

    <item name="CivSedanDoors_BackRight" chance="1" />

    </attachments>

    <attachments chance="1">

    <item name="CivSedanHood" chance="1" />

    </attachments>

    <attachments chance="1">

    <item name="CivSedanTrunk" chance="1" />

    </attachments>

    <attachments chance="1">

    <item name="CanisterGasoline" chance="1" />

    </attachments>

    <attachments chance="1">

    <item name="WaterBottle" chance="1" />

    </attachments>

    <attachments chance="1">

    <item name="WaterBottle" chance="1" />

    </attachments>

    <attachments chance="1">

    <item name="WaterBottle" chance="1" />

    </attachments>

    <attachments chance="1">

    <item name="WaterBottle" chance="1" />

    </attachments>

    <attachments chance="1">

    <item name="WaterBottle" chance="1" />

    </attachments>

    <attachments chance="1">

    <item name="WaterBottle" chance="1" />

    </attachments>

    </type>

    Again my modded Server keeps crashing again; sometimes after a couple of minutes sometimes adhoc after pressing the play button.

    For weeks it hadn't any crash even without restarting it for 3-4 days. No changes made...

    On PC-Version I can't see any problems in the logs.

    Because Nitrado offers no crashlogs and their support ignored this repetitive server crashes for month now when I submit a ticket I want wo ask if someone here has the same problems.

    By the way; here a short list of websites & online-tools I use for modding frequently.

    VANILLA XML files version 1.08
    Chernarus Direct-Link: dayzoffline.chernarusplus
    Livonia Direct-Link: dayzoffline.enoch

    All tools und files (even modding samples) von Bohemia

    Bohemia Repositories: https://github.com/bohemiainteractive/

    DayZ TYPES.XML modifier
    dayz.skyn1.se

    Lists with class-names of the items ingame (even some removed but working like sword, wodka...)
    https://github.com/cyphermediagit/dayzclassnames2020/blob/master/classname2020
    https://github.com/ravmustang/dayz_sa_classname_dump/tree/master/everything%20dayz

    Download your log-files via WebUI and post them here to visualize events on map
    iZurvive DayZ & ARMA Map: Chernarus+ Terrain

    DayZ Wiki
    https://dayz.gamepedia.com/dayz_standalone_wiki

    XML Validator (to check if your files are well-formed and valid which is essentially to NOT perma-crash the server)
    Free Online XML Validator (Well formed)

    For those who like video tutorials; Don Sibley posted some on Youtube. He is very creative but it looks like he sometimes tries things for the first try and he's "trial&error"-ing here and there. I used his tutorials for cars and dynamic npcs/hordes and planning to build a bridge to prison island like he did.