Posts by TremorTaco

    I created a server with mods, when I enter the IP on my PC and try to connect to the server it says "Can't connect to server" I checked the logs and there is an error, I looked for it on google but found no answer, here is the log.


    [00:35:01] [Server thread/INFO]: Starting minecraft server version 1.12.2

    [00:35:01] [Server thread/INFO]: Loading properties

    [00:35:01] [Server console handler/ERROR]: Exception handling console input

    java.io.IOException: The handle is invalid

    at java.io.FileInputStream.readBytes(Native Method) ~[?:1.8.0_231]

    at java.io.FileInputStream.read(Unknown Source) ~[?:1.8.0_231]

    at java.io.BufferedInputStream.read1(Unknown Source) ~[?:1.8.0_231]

    at java.io.BufferedInputStream.read(Unknown Source) ~[?:1.8.0_231]

    at sun.nio.cs.StreamDecoder.readBytes(Unknown Source) ~[?:1.8.0_231]

    at sun.nio.cs.StreamDecoder.implRead(Unknown Source) ~[?:1.8.0_231]

    at sun.nio.cs.StreamDecoder.read(Unknown Source) ~[?:1.8.0_231]

    at java.io.InputStreamReader.read(Unknown Source) ~[?:1.8.0_231]

    at java.io.BufferedReader.fill(Unknown Source) ~[?:1.8.0_231]

    at java.io.BufferedReader.readLine(Unknown Source) ~[?:1.8.0_231]

    at java.io.BufferedReader.readLine(Unknown Source) ~[?:1.8.0_231]

    at nz$2.run(SourceFile:100) [server.jar:?]

    [00:35:01] [Server thread/INFO]: Default game type: SURVIVAL

    [00:35:01] [Server thread/INFO]: Generating keypair

    [00:35:01] [Server thread/INFO]: Starting Minecraft server on *:25565

    [00:35:01] [Server thread/INFO]: Using default channel type

    [00:35:01] [Server thread/INFO]: Preparing level "world"

    [00:35:01] [Server thread/INFO]: Loaded 488 advancements

    [00:35:01] [Server thread/INFO]: Preparing start region for level 0

    [00:35:02] [Server thread/INFO]: Done (1.155s)! For help, type "help" or "?"

    [00:35:14] [Server thread/INFO]: Stopping server

    [00:35:14] [Server thread/INFO]: Saving players

    [00:35:14] [Server thread/INFO]: Saving worlds

    [00:35:14] [Server thread/INFO]: Saving chunks for level 'world'/overworld

    [00:35:14] [Server thread/INFO]: Saving chunks for level 'world'/the_nether

    [00:35:14] [Server thread/INFO]: Saving chunks for level 'world'/the_end

    [00:35:14] [Server Shutdown Thread/INFO]: Stopping server

    [00:35:14] [Server Shutdown Thread/INFO]: Saving players

    The mods appear on the creative mode, and I can place them on my bar, but I can't place them on the map they instantly dissapear. I have installed the mod of animations and it works, but the others won't, I have them install on the Nitrado Server, and on my client, the mods and server are in version 1.12.2