Server wont intialize

Dear forum members,
for some time now we have been creating and maintaining new ways to help game server admins with questions and problems as quickly as possible, e.g. our Guides section and the Nitrado Community Discord.

Therefore, we inform you that the Nitrado Forum will be closed on March 31, 2023. We are consolidating our community support to our Discord channel, which is faster and more efficient. We have also seen incredible growth in our community due to the hard work of our moderators and our bots. We are confident that this move will ensure that we provide the best support possible for our users.

Thank you to all members for your continued use of the forum!

Assistance with all questions concerning your Nitrado service can now be found in these spots:
Community Discord:
Guides section:
Support Wizard:
  • I just uninstalled and reinstalled the game thinking maybe that would fix the issue at hand, lost several hours of play doing this :cursing::cursing:

    Server is not showing up in the list and when i try to connect manually it just tells me "Server is still initializing, please try again in a minute" its been over 20 minutes since I reinstalled, set up the the config files and restarted the server to apply changes. Dashboard says the server is runing and there is memory usage but no cpu activity.

    anyone here have a fix or this a tech issue Nitrado has on their end?

  • I have same problem, i dont have acess to my server 14 hours.

    I try reinstall server 3 times, and still have same issue. "Server is still initializing, please try again in a minute"

    Any idea how to fix it?

    I issued ticket yesterday, but still no one answered me.

  • I had the same issue. Called the support and they refunded me to allow me to reorder the server. I did that and was told I could just move the world file into the new server files. I did so and now I am in the same situation as before. I at this point just want to start over and don't want my save files back, but I can't even get past "Server is still initializing, please try again in a minute."

  • I am also having the same issue. Contacted support. They told me it is a known issue and there is a specific fix that must be applied by sending a ticket for support. I received a reply back to my ticket stating they have applied the fix, but I am still unable to access my server 5 hours later. I have not been able to access my game server ONCE since renting the server. Still waiting on resolution.

  • So from my OWN testing, it is just A19. You will not have your save but if you install A18 then it will work fine. Server was up within a couple minutes after it installed.

    After the update to 7d2d on steam on the 17th it has not worked for me.

  • I had the same issue after the update on the 17th with the Navezgane map we were running. I changed the map to a pregen and it has been working fine. I have tried to load the saved Navezgane map and a new Navezgane map as well, but the server never starts all the way. There must be an issue with that map or something. You can have multiple games saved on the server and toggle between them as well.