Has anyone gotten the new 12.2.3 update yet?

Become part of a great team that has nothing less as its goal than to be the world's best game server provider. Keep facing new, challenging and exciting tasks at a company that values your opinion.


open positions @ Nitrado
  • As the title states, has anyone gotten the new 12.2.3 update yet?


    My panel in the top-left interestingly shows 12.2.1, but it says "Last Game Update" was Jul 9, 2020, 4:46:42 AM.


    Server won't let me connect anymore presumably because of the version difference.

  • so i got off the phone with the support dudes and they said to restore a backup copy to update the server or reinstall it to update it so im currently doing that, under the server settings in steam set your profile id and save then start the server and try to connect via ip and port it should let you connect about 5 min after server restarted

  • so i got off the phone with the support dudes and they said to restore a backup copy to update the server or reinstall it to update it so im currently doing that, under the server settings in steam set your profile id and save then start the server and try to connect via ip and port it should let you connect about 5 min after server restarted


    My Nitrado says there's no restore backup available. :( Is there a way to save my game and "import" it after reinstalling?

  • I have a similar question. My game has also not updated - it had other issues which have seem to resolved now but the lack of update is the last thing stopping us playing now.


    In a ticket, support advised "In order to update the server, you will need to perform a reinstall of the game. "


    I am a little confused here! I have been with Nitrado for less than a month and the few previous updates have eventually appeared without any action from me. Do we now have to update our own server? Is it the new norm? If so I will have to check into ftp programs to back up our game files first I guess, as I assume a reinstall nukes all saves.


    Thought I'd keep you posted!


    I have reinstalled the server - having backed up what I think are my game files. The event log shows that the game was installed at 1108. It restarted a couple of times but has shown as running for about 10 minuts now. So far:


    - the CPU and RAM graphs are empty - as in not visibly running

    - have a new IP

    - no version yet


    Will wait for awhile longer to see what happens. Will update when something does!


    Just went in


    - CPU/RAM graphs working

    - updated version number shown!!


    Tried to connect to server - it worked as it threw me out for not having EAC enabled on the client. Stopped server to make config changes - EAC off, password etc. Have just restarted server - will see what happens next....


    Waited 10 minutes - although the server says it has started, no version number came up. I can only connect when this is displayed. Usually this appears after about 7 minutes - if there is no error log file.


    There was no log file so I was quite hopeful..... sadly no version number came up after 7 mins (10 in this case) . So I have tried Comp625 suggestion (in another thread) to press the restart button. For reference all the other times I have said I have restarted the server, I should have said that I in fact used the stop and start buttons - not the restart button.


    Am in the middle of waiting another 10 mins to see if the restart has worked. FIngers crossed.


    3 restarts later - no joy. No version number and logs showing ap64 load errors. Oh well.


    For extra fun I tried a restore of this morning's pre-reinstall backup. The file is only 8mb so I was half expecting it to be a save game of some sort. On running the restore, it said it was doing a reinstall.


    In any case, it still failed with api load errors in the log.

  • Same boat, as far as not updating. I opened a support case and response so far has only been they are looking at it.


    Dhansak, I have found you don't need to wait the 10 min or so for the server to come back up. If you watch the /empyrion/Logs/Dedicated_[Date].log and it stops at 7kb and the server isn't up yet its not coming up. (I just leave a connection of WinSCP open and refresh it after the Nitrado web says the server is started to see the file size.) The log will contain

    Quote

    "Plugins: Failed to load 'C:/SERVICES/ni4393823_2_SHARE/ftproot/empyrion/DedicatedServer/EmpyrionDedicated_Data/Plugins/steam_api64.dll' because one or more of its dependencies could not be loaded."

    Finding this allowed me to restart quicker. I basically just restart every 2-3 minutes until it comes up, longest so far has been 53 restarts taking about 2 hours. I have also had it only take 2-3 restarts so kind of random. Note- Restart vs full shutdown startup didn't seem to matter for me.


    This does appear to be solvable though. If you create the folder /empyrion/DedicatedServer/EmpyrionDedicated_Data/Mono and copy the steam_api64.dll (you can find it in /empyrion/DedicatedServer/EmpyrionDedicated_Data/Plugins/) it seems to fix the error and a restart has worked every time for me.


    My understanding is this is an Empyrion issue not Nitrado, they "removed" this dependency back in like Alpha 10, but seems it has creeped its way back somehow (poor code control would be my guess). Credit and much more detailed explanation goes to jpf190279 at the bottom of this thread... Server is hanging in loading screen


    Doesn't solve the no-update issue, and admittedly from reading the forums it seems like there could be another connection issue people are seeing, but I can't tell for sure so can only share my experience so far. Hope it helps.

  • After not hearing back for 18 hours on my ticket I ended up just called support. Level 1 just tried to shutdown and startup the server. I suppose if they can see the actual VM go into a power off state there is value in that test but that didn't help and I was just told they had to escalate to the level 2. They could not give any timeframe for someone to look at the issue.

    Per Comp625 's recommendation I did try Stop Server > Start Sever > Reboot. My first attempt to connect to the server crashed my local game client but upon another try I was able to get into the game. My friends (4) had no issues connecting.


    xjeepstuffx thank you for the feedback and I will keep that in mind. Unfortunately the automated backups of the server stopped working a few days ago (and I didn't notice) so have been trying to avoid a server reset.


    Thank you all for the support, (its been better then from the company)