Server is hanging in loading screen

Become part of a great team that has nothing less as its goal than to be the world's best game server provider. Keep facing new, challenging and exciting tasks at a company that values your opinion.


open positions @ Nitrado
  • I had the same issue but after many attempts to restart the server I discovered that the server was not fully loaded when trying to log in. The dashboard will say "Server Started" but in fact it has not fully loaded yet. After starting the server, refresh your dashboard window every few minutes. After some time, once the server is ACTUALLY loaded, you will see a user counter and the server's game version pop up on the dashboard. Once the dashboard is showing both a user counter AND the version number, the server is ACTUALLY stated and you can connect. I find it very bad form that Nitrado does not have some message on the dashboard to tell you this but I guess they don't care much. Also you need to make sure that you have EAC activated on the server configuration, and also on the game client of each user tying to connect.


    Hope this helps you as Nitrado doesn't seem to care enough to respond to these threads and give you the info. :(

  • natpoho these are the community support forums. Us mod do not hace access to your servers or account. We work together as a community to fix issues some issues may require a support ticket. If a thread doesn't get answered its not that Nitrado doesn't care it could be simply the community like yourself didnt have an asnwer at that time. Again i do apologize that you weren't happy with no one replying.

  • I am having the same issue, and it takes so long for the server to restart, i also run a server from home and that server restarts in 30 seconds, but it seems my nitrado server takes 5 or more minutes. These servers are not hardware intensive by any means, and it taking so long when i can start it in 30 seconds on an old laptop is just unacceptable as a server host.

    Nitrado needs to find out why they are taking so long to restart and correct that issue. Nitrado also needs to update their dashboard to properly reflect that the server has not completed startup, maybe say running once the startup is complete.

    I am disappointed that I am able to host a server from home on a 6 year old laptop much more efficiently than the server host I am paying for.

  • OK im having serious issues... First i could not get to the moon in the game... SO i reloaded the server, Set it up like before and tried to load in...

    Well i got to the selection screen of which planet and chose one.. then it hangs there on LOADING... i had it going for 25 minutes...

    HELP PLEASE!!!?(

    There is The cutting edge... the bleeding edge... then there is the Stark Edge!

  • I am getting corrupted Playfields. What does this mean? I've tried starting on a couple planets, each time I get


    27-16:34:35.156 12_34 -WRN- Removing client id 5 from connect waiting list because target playfield Eutym is corrupted

  • Hey all!


    Can confirm that I wasn't able to join the server I got the same thing, infinite loading screen and corrupted playfield in the logs.


    /Merged the threads I could find and made it a mega thread as well as pinning it.


    Looking into this right now.


    ---

    UPDATE #1

    Appears to be an issue with the game server itself, developers are looking into a fix.

    I did just install a fresh server and it launched fine, was able to connect and spawn in, in-game. [I landed on a hill and it rolled away from me :( ]

    The suggested solution is to restart the server until you're able to connect for now.


    Source#1 (Below) / Source#2 (Not screenshotted)


    /ThreadClosed while we wait for a patch. :)

  • Mekki

    Closed the thread.
  • Hi Guys,


    Sorry to barge in but I had the same issue and managed to resolve it... The issue HAS far as I can tell is due to missing dependencies from an NOW missing folder on the dedicated server for Empyrion.


    If you check your server logs you might see an error message along the lines of missing file dependencies lib_steam64.dll and steam_api64.dll (sorry - my error logs got cleared and so I am wrting it out from memory). This for me started happening when I added my steam 64 ID to the adminconfig.yaml file.


    So when you add your steam ID into the file, obviously the server must check it against steam to verify you are who you say you are, to do this, the server called Steam_api64.dll from the /empyrion/DedicatedServer/EmpyrionDedicated_Data/Plugins/ file (lots of assumptions here) to do the verification. This plugin inturn appears to tryand called both the lib_steam64.dll and steam_api64.dll files from a now non-existent folder called /empyrion/DedicatedServer/EmpyrionDedicated_Data/Mono/. Obviously this will cause the server to effectively go oh-noes I can't do that and stop.


    Initially the only way I could get this to work was to remove my Steam 64 ID from the adminconfig.yaml and start with any admin functionality. This appeared to work but I wasn't happy with having no admin control. So I thought to myself, what exactly is the error complaining about? After looking at the error logs again, I realised that only 1 of the 2 files that message referred to was actually causing an issue, the Steam_api64.dll file.


    So I tried the following;


    1.) Obviously shutdown the server first!!!!!!

    2.) Open FTP and connecting to the host

    3.) Going into folder /empyrion/DedicatedServer/EmpyrionDedicated_Data/

    4.) Creating a new folder called 'Mono'

    5.) Going into folder /empyrion/DedicatedServer/EmpyrionDedicated_Data/Plugins/

    6.) Downloading a copy of steam_api64.dll to my local machine to the Desktop area

    7.) Going into folder /empyrion/DedicatedServer/EmpyrionDedicated_Data/Mono/

    8.) Uploading a copy of steam_api64.dll from my local machine to the Mono folder

    9) Start the server again!!!!!


    When the server came back up the error for the missing dependencies vanish, the server started no problems, I was able to connect and best of all I had full admin control as I asked for in the adminconfig.yaml file.


    Now I am not sure why this has become an issue all of a sudden, Eleon has had other report of this issue occuring for the EAH tool, but they claimed the dependency on the old Mono folder was no longer an issue. In fact they have stated it was removed several releases ago. Clearly something has gone a tad WRONG.


    I hope this helps people, I am seeing a lot of complaints about servers not starting no the forums.


    Anyhow, good luck.

  • Hi, just a question:


    Isnt this what we are paying them to do??

    My server was down for all but two days now, yet they already sent me the warning regarding the ending of the rented time (again, that i had availabel to play for 2 days). I need to count the amount of tickets i sent now.


    Funny the priorities of this people...


    Cheers.