Unable to apply settings

  • All the changes to the settings i make such as DiffConstrCraftTime revert back to default after restarting the server. Here is my process:


    -Stop server

    -Go to the general tab under settings

    - Make changes to the fields such as DiffConstrCraftTime , Enable Volume Weight and password.

    -I hit save changes and wait for the confirmation message

    -I click the start server button and wait for it to load on Empyrion

    -Join server


    Results

    -Only the password change is applied and nothing else. All of other changes are reverted back to default.


    This is the first time i am hosting a server with Nitrado, am i doing something wrong? Is there anything i could try?

    Thanks!

  • I was having this issue also. I edited the options using the link in the dashboard called "Config Files". Edit the files in that window and click save. If that doesn't work, download the file by clicking download, then edit it locally, then upload and over-write the old file. Hope this helps.

  • I've had the same issue and can confirm the fix the other user posted.


    "If that doesn't work, download the file by clicking download, then edit it locally, then upload and over-write the old file." natpoho


    Trying to make any changes and save in the web interface fails. You have to export the .json file, edit it using notepad or something similar, then upload. Once its uploaded all those changes stick.


    As usual the nitrado service sucks and didn't help at all, took trial and error.


    Hopefully this helps!

  • I am wondering, when there is a settings-thingy, why the hell we have to change settings localy on our system and then reupload via ftp to the server. We tried nearly everything we could think of, besides ftp, like changing via the settings option of nitrado, changing ingame via console, etc, but nothing works. That is really frustrating. And when you head to forum and all you read is no solution yet or the customer support told me to check forum it gets even worse. We now switched to another hoster cuz we are tired of this stuff.

    And it is not just with Empyrion, we had this issue with other games, too. Think we even once got the answer, that only staff is able to change some settings on another game. But this doesnt get mentioned anywhere and the support for germany isn't that great. At 6pm you are left alone and stuck with whatever problem you have.

  • We have the same issue since update 12.1. I will try the suggested solution, thanks. We've rented this service not even 1 week ago and so many problems, and tickets don't get replied, posted one yesterday, still waiting.

  • THANK YOU natpoho it seems to be working for me too!! Here's my process:

    - Stop server
    - Go to Config Files
    - Backup gameoptions.yaml (just in case)

    - Open gameoptions.yaml locally, edit with all desired options, save and upload.

    - Start server
    Thanks a lot guys. Cheers.

  • hello


    i m very bad with computer, and i have same problem for setting my server


    anyone wan be admin of my server for setting it correctly please ?


    the option number 2 in the file is ok but the server not use it look like


    please help me :)

  • it s fine a friend help me, the problem is the YAML not work with command in a line, you need to enter each line command and make a space between command true or false also remove the # and line default if oyu put a true or false order


    this is a copy of my setting for normal setting difficulty with weight and cpu limit activ:

    fodler: gameoption.yaml


    # For more details, see gameoptions_example.yaml in Content\Scenarios\Default Random

    Options:

    - ValidFor: [ SP, Survival ]

    DecayTime: 0

    WipeTime: 0

    ProtectTime: 0

    ProtectDelay: 0

    MaxStructures: 255

    AntiGriefDistancePvE: 0

    AntiGriefDistancePvP: 0

    AntiGriefOresDistance: 0

    # AntiGriefOresZone: PvE

    EnableTrading: Player2System

    EnableMaxBlockCount: true

    EnableVolumeWeight: true

    EnableCPUPoints: true

    AutoMinerDepletion: false

    GroundedStructureSpawn: true

    TurretUndergroundCheck: true

    # OriginDefault: Neutral # default value

    # OriginAccessOthers: True # default value

    # OriginAutoAlliance: True # default value

    # FriendlyFireInPvP: True # default value

    # MaxSpawnedEnemies: 60 # default value

    DespawnEscapePod: false

    RegeneratePOIs: true

    # FOWTransparency: 0 # default value

    # DSLUnloadSecs: 30 # default value

    # DSLDistancePlanet: 1200 # default value

    # DSLDistanceSpace: 3000 # default value

    # ForcePvP: False # default value

    OriginFactionStart: true

    ThrustersNeedOpenSpace: true


    - ValidFor: [ MP, Survival ]

    # DecayTime: 24 # default value

    WipeTime: 720

    ProtectTime: 24

    ProtectDelay: 1800

    MaxStructures: 500

    # AntiGriefDistancePvE: 30 # default value

    # AntiGriefDistancePvP: 300 # default value

    # AntiGriefOresDistance: 30 # default value

    # AntiGriefOresZone: PvE # default value

    # EnableTrading: All # default value

    EnableMaxBlockCount: True

    EnableVolumeWeight: true

    EnableCPUPoints: true

    AutoMinerDepletion: False

    GroundedStructureSpawn: True

    TurretUndergroundCheck: True

    # OriginDefault: Neutral # default value

    # OriginAccessOthers: True # default value

    # OriginAutoAlliance: True # default value

    # MaxSpawnedEnemies: 60 # default value

    DespawnEscapePod: True

    RegeneratePOIs: True

    # FOWTransparency: 0 # default value

    # DSLUnloadSecs: 30 # default value

    # DSLDistancePlanet: 1200 # default value

    # DSLDistanceSpace: 3000 # default value

    # ForcePvP: False # default value

    OriginFactionStart: true

    ThrustersNeedOpenSpace: true

    # UndergroundBpSpawn: Always # Permission for spawning Blueprints below terrain [Always (default), PvE, Never]


    ### In local Coop, following parameter are ignored since they are taken from Difficulty Settings window ###

    FriendlyFireInPvP: True

    # DiffEscapePodContent: Medium # default value

    # DiffPlayerProgression: Normal # default value

    # DiffDegradationSpeed: Normal # default value

    # DiffFoodConsumption: Normal # default value

    # DiffOxygenConsumption: Normal # default value

    # DiffRadiationTemperature: Normal # default value

    # DiffAmountOfOre: Normal # default value

    # DiffNumberOfDeposits: Normal # default value

    # DiffAttackStrength: Medium # default value

    # DiffEnemySpawnRate: Normal # default value

    # DiffDronePresence: Normal # default value

    # DiffDroneBaseAttack: Medium # default value

    # DiffConstrCraftTime: Normal # default value

    # DiffBpProdTime: Normal # default value

  • I edited my files locally and uploaded them through ftp. Now when I click on config files in the dashboard it shows all my settings correctly but in the game I still lose all my stuff if I die and creating things is not instant like I set it. Both of these I can probably deal with (I'm new and set everything super easy to get used to the game) but I'm not sure about other settings, those are ones I tested to see if it was working.


    So does that mean there are some settings we cant control or is there an issue?