Unable to apply settings

Nitrado now has an official Discord server to bring communities, friends and other gamers together!
Join the Nitrado Community Discord now and share your experiences and knowledge with others!

Click here to go to the Discord Server!
  • All the changes to the settings i make such as DiffConstrCraftTime revert back to default after restarting the server. Here is my process:


    -Stop server

    -Go to the general tab under settings

    - Make changes to the fields such as DiffConstrCraftTime , Enable Volume Weight and password.

    -I hit save changes and wait for the confirmation message

    -I click the start server button and wait for it to load on Empyrion

    -Join server


    Results

    -Only the password change is applied and nothing else. All of other changes are reverted back to default.


    This is the first time i am hosting a server with Nitrado, am i doing something wrong? Is there anything i could try?

    Thanks!

  • I was having this issue also. I edited the options using the link in the dashboard called "Config Files". Edit the files in that window and click save. If that doesn't work, download the file by clicking download, then edit it locally, then upload and over-write the old file. Hope this helps.

  • I've had the same issue and can confirm the fix the other user posted.


    "If that doesn't work, download the file by clicking download, then edit it locally, then upload and over-write the old file." natpoho


    Trying to make any changes and save in the web interface fails. You have to export the .json file, edit it using notepad or something similar, then upload. Once its uploaded all those changes stick.


    As usual the nitrado service sucks and didn't help at all, took trial and error.


    Hopefully this helps!

  • I am wondering, when there is a settings-thingy, why the hell we have to change settings localy on our system and then reupload via ftp to the server. We tried nearly everything we could think of, besides ftp, like changing via the settings option of nitrado, changing ingame via console, etc, but nothing works. That is really frustrating. And when you head to forum and all you read is no solution yet or the customer support told me to check forum it gets even worse. We now switched to another hoster cuz we are tired of this stuff.

    And it is not just with Empyrion, we had this issue with other games, too. Think we even once got the answer, that only staff is able to change some settings on another game. But this doesnt get mentioned anywhere and the support for germany isn't that great. At 6pm you are left alone and stuck with whatever problem you have.

  • We have the same issue since update 12.1. I will try the suggested solution, thanks. We've rented this service not even 1 week ago and so many problems, and tickets don't get replied, posted one yesterday, still waiting.

  • THANK YOU natpoho it seems to be working for me too!! Here's my process:

    - Stop server
    - Go to Config Files
    - Backup gameoptions.yaml (just in case)

    - Open gameoptions.yaml locally, edit with all desired options, save and upload.

    - Start server
    Thanks a lot guys. Cheers.

  • hello


    i m very bad with computer, and i have same problem for setting my server


    anyone wan be admin of my server for setting it correctly please ?


    the option number 2 in the file is ok but the server not use it look like


    please help me :)

  • it s fine a friend help me, the problem is the YAML not work with command in a line, you need to enter each line command and make a space between command true or false also remove the # and line default if oyu put a true or false order


    this is a copy of my setting for normal setting difficulty with weight and cpu limit activ:

    fodler: gameoption.yaml


    # For more details, see gameoptions_example.yaml in Content\Scenarios\Default Random

    Options:

    - ValidFor: [ SP, Survival ]

    DecayTime: 0

    WipeTime: 0

    ProtectTime: 0

    ProtectDelay: 0

    MaxStructures: 255

    AntiGriefDistancePvE: 0

    AntiGriefDistancePvP: 0

    AntiGriefOresDistance: 0

    # AntiGriefOresZone: PvE

    EnableTrading: Player2System

    EnableMaxBlockCount: true

    EnableVolumeWeight: true

    EnableCPUPoints: true

    AutoMinerDepletion: false

    GroundedStructureSpawn: true

    TurretUndergroundCheck: true

    # OriginDefault: Neutral # default value

    # OriginAccessOthers: True # default value

    # OriginAutoAlliance: True # default value

    # FriendlyFireInPvP: True # default value

    # MaxSpawnedEnemies: 60 # default value

    DespawnEscapePod: false

    RegeneratePOIs: true

    # FOWTransparency: 0 # default value

    # DSLUnloadSecs: 30 # default value

    # DSLDistancePlanet: 1200 # default value

    # DSLDistanceSpace: 3000 # default value

    # ForcePvP: False # default value

    OriginFactionStart: true

    ThrustersNeedOpenSpace: true


    - ValidFor: [ MP, Survival ]

    # DecayTime: 24 # default value

    WipeTime: 720

    ProtectTime: 24

    ProtectDelay: 1800

    MaxStructures: 500

    # AntiGriefDistancePvE: 30 # default value

    # AntiGriefDistancePvP: 300 # default value

    # AntiGriefOresDistance: 30 # default value

    # AntiGriefOresZone: PvE # default value

    # EnableTrading: All # default value

    EnableMaxBlockCount: True

    EnableVolumeWeight: true

    EnableCPUPoints: true

    AutoMinerDepletion: False

    GroundedStructureSpawn: True

    TurretUndergroundCheck: True

    # OriginDefault: Neutral # default value

    # OriginAccessOthers: True # default value

    # OriginAutoAlliance: True # default value

    # MaxSpawnedEnemies: 60 # default value

    DespawnEscapePod: True

    RegeneratePOIs: True

    # FOWTransparency: 0 # default value

    # DSLUnloadSecs: 30 # default value

    # DSLDistancePlanet: 1200 # default value

    # DSLDistanceSpace: 3000 # default value

    # ForcePvP: False # default value

    OriginFactionStart: true

    ThrustersNeedOpenSpace: true

    # UndergroundBpSpawn: Always # Permission for spawning Blueprints below terrain [Always (default), PvE, Never]


    ### In local Coop, following parameter are ignored since they are taken from Difficulty Settings window ###

    FriendlyFireInPvP: True

    # DiffEscapePodContent: Medium # default value

    # DiffPlayerProgression: Normal # default value

    # DiffDegradationSpeed: Normal # default value

    # DiffFoodConsumption: Normal # default value

    # DiffOxygenConsumption: Normal # default value

    # DiffRadiationTemperature: Normal # default value

    # DiffAmountOfOre: Normal # default value

    # DiffNumberOfDeposits: Normal # default value

    # DiffAttackStrength: Medium # default value

    # DiffEnemySpawnRate: Normal # default value

    # DiffDronePresence: Normal # default value

    # DiffDroneBaseAttack: Medium # default value

    # DiffConstrCraftTime: Normal # default value

    # DiffBpProdTime: Normal # default value

  • I edited my files locally and uploaded them through ftp. Now when I click on config files in the dashboard it shows all my settings correctly but in the game I still lose all my stuff if I die and creating things is not instant like I set it. Both of these I can probably deal with (I'm new and set everything super easy to get used to the game) but I'm not sure about other settings, those are ones I tested to see if it was working.


    So does that mean there are some settings we cant control or is there an issue?

  • sono per ora due impostazioni che non controlla e dove io sto cercando di capire da giorni.

    1) nella nuova versione è stato aggiunto : quando muori se inpostato su facile non si perde nulla nello zaino e nella cinta se impostato su medio si perde solo quello che si ha nella cinta, se impostato su difficile si perde tutto.

    2) non carica nella sezione Custom Scenario lo scenario che io voglio caricare, ma mette la mappa di base

  • This is still a problem for me. Even the support at Nitrado has been unable to figure it out yet. Read from an Empyrion support online, it was a file that has limited permissions, but that was an old conversation, so unsure. Nitrado seems to be working on it, which is good.

    I went outside once. The graphics were amazing, but the game play sucked.

  • I am having the same issue
    did the whole download the .yaml file and changed everything i wanted

    Uploaded new file

    saved changes

    started server

    Logged into it and still no change.
    Is there another way to do this that im not thinking of? possibly another work around?

  • Hi,


    i had the same problem with the yaml configuration files.

    I found out that yaml is sensitive for formating (spaces and tabs), so you need a specific file structure!

    The server will load the default settings, if the yaml structre is not correct.

    Have a look at my config as a example, it works how I want it. (attached to this post)

    You can upload it to your configuration and change the settings and remove the ".txt" ending in its file name.

  • This still did not work for me, but I am having more issues than just the settings not applying. From server crashing to server shutting down for hours, and the ram being much less than said upon purchase. I have given up and am requesting a refund. Just seems that the slew of problems with hosting on this provider outweighs the positive aspects. I have never rented a server before, but I have hosted my own from home many times, and never had such complications. I will try another service and see if it is better.

    I went outside once. The graphics were amazing, but the game play sucked.

  • This still did not work for me, but I am having more issues than just the settings not applying. From server crashing to server shutting down for hours, and the ram being much less than said upon purchase. I have given up and am requesting a refund. Just seems that the slew of problems with hosting on this provider outweighs the positive aspects. I have never rented a server before, but I have hosted my own from home many times, and never had such complications. I will try another service and see if it is better.

    Any idea how to download the save game file so i can switch my server? Gonna try and Host on my machine. Plus i have been Messaging support back and forth for the past week or 2 and this is their final reply:


    Hello,



    The setting is correctly set in the configfile, if it is not accepted, it is a difficulty of the server software, in this case unfortunately, we can't change the game's behavior, nor the one of its server software because we have no access to it's code. I would recommend you to contact the "ELEON GAME STUDIOS" Support directly:



    -> Empyrion – Galactic Survival

    So, It seems like they have given up. Even though you can set settings on your local files and they apply just fine *single player*. I still believe that there is something wrong on their end but idk.

  • Well, bizarre enough, I setup a server on my computer to test it out, and settings work fine, and update fine, with no issues at all. I can say this is not a normal server running experience for Empyrion, and has something to do with the setup that Nitrado has. I had a server working exactly how I wanted within a few hours, while weeks of struggling failed to achieve anything on the rented server.

    I went outside once. The graphics were amazing, but the game play sucked.

  • You can download your files from the files menu where you browse your files. I no longer can view it to walk you through it per step, but I am sure someone still does here. It is not difficult, once you find it though, as there is a download option. However, my save game file did not want to cooperate, trying multiple backups and saves, none of them worked right, and seem to be missing some information within the files.


    What causes this, I am uncertain, but I am finding that the private server game saves are having trouble anyhow. There are trade-offs in everything.


    Depending on what you are trying to change, you can also alter the .ecf files to adjust to your desires, but this is limited in the scope of some things, like regenerating poi's and the sort. The real thing needed is support for the empyrion helper included with the game. I was told by their customer service that it is a third party application, which is not true, so I guess it just takes time for them to realize that is the admin tool and make allowance for it.

    I went outside once. The graphics were amazing, but the game play sucked.