SCUM Servers - An Update

  • UPDATE #1

    Just wanted to give you all an update!


    Five separate things:

    1.

    Database operation failed! issue Fixed


    2.

    "Reserved Player" "Admin Access" "BanList" and "Exclusive Join" lists are missing, will be added soon! Added


    3.

    BlueprintsAutoDestroyTime default is 21600 (We currently limit it to 1800) Fixed

    MaxAllowedAnimalsInWorld default is 100 and should be able to be 0. (Currently must be 100 or more) Fixed

    SectorCooldownResetMultiplier=0 by default (currently missing) Added


    4.

    Descriptions for a lot of the settings are not added yet (On the to do list) <- Still on the to-do list :)


    5.

    Ports are misleading on the webinterface, will be updated! <- Still on the to-do list :)


    Thanks for your patience everyone! Will bring you updates as I get them!




    UPDATE #2

    Any issues with the servers launching should now be resolved.


    Please be sure to:

    1. Stop your server
    2. Navigate to General Settings
    3. Click Save Changes
    4. Start your server


    Troubleshooting:

    Problem: Still getting "Database operation failed!" at the end of character creation.

    Solution: Reinstall the server in the webinterface. (Should take ~5mins)


    We'll have another update for you tomorrow!



    UPDATE #3


    You should all have received an E-Mail which also includes the details of compensation for lost time!




    Update #4


    Additional time has been added to all SCUM server owners to ensure no paid time was lost.


    Working closely with Gampires we have now resolved several of the key issues. We will continue to work diligently to ensure the servers are functioning to the high standards you expect from us.


    We want to thank you for your patience with us, your input, contribution and the trust that we would get it fixed!


    If you’re still experiencing Database Operation Failed! Please reinstall the server via the webinterface to fix that issue.


    If you have an open ticket regarding your server, we would kindly ask you to close it unless your issue is still occurring, someone from our support team will get back to you soon!

  • UseMapBasedBuildingRestriction - This should be displayed as an on/off checkbox or button, not a value to input.

    The admin list etc is pretty vital to us server owners so can we have a rough ETA on when these issues will be fixed/implemented? This is the least you guys can do considering the SCUM server launch fail and the failure to support us customers from the start also.


    Don't get me wrong, I appreciate you guys are now listening and have made some steps forward but Nitrado has some making up to do.


    I can now see that you have added: SectorCooldownResetMultiplier


    However its been added as a checkbox when it should be a value to be entered.


    This is resulting in being unable to save the config.


    Also many of the default values you have set for each setting are way off what they should be.


    This is not going well Mekki.


    Another one:


    MaxAllowedSentriesInWorld - default setting for this is -1 but you guys have set it to require at least 0


    Apologies, I see you have merged my posts but I cant seem to edit the merged post now in order to add further feedback:


    SectorCooldownResetMultiplier - this needs to be placed under the RespawnSettings section


    Something is still not right. For example i have the following set in my configuration:


    RandomLocationPrice=0
    SectorLocationPrice=20

    ShelterLocationPrice=40


    However in game its appearing as if the following is set:


    RandomLocationPrice=25

    SectorLocationPrice=50

    ShelterLocationPrice=75


    So it looks like some custom settings are not being applied?


    BatteryChargeWithDynamoMultiplier - This setting is missing



    Did the SCUM Devs not give you guys a list of the server settings, descriptions and default values?

  • Hiyas, Just joined as I was hoping to get my own server.

    As far as I can tell, Nitrado is not currently able to properly host SCUM. Is that correct?

    I would hold off until Nitrado confirm that all issues have been resolved.



    Right Mekki, I have just completed some work for you guys in order to speed this up. Please see a list of all settings, with their default values, along with descriptions (everything after // is a description, not a value).


    Check out the below spoiler!


  • Mekki im finding more and more wrong with the config on Nitrado.


    Please take notice of my previous post where I have included a spoiler with ALL server settings, along with their default values, descriptions and what type of entry they should be (checkbox or value). That is the FULL LIST of server settings available. I've noticed that Nitrado are missing a few at the moment and some listed on the config page are incorrect and/or do not exist.


    Please get the web devs to re-work the config page using the list i provided in my previous post and everything will then be correct! (SCUM Servers - An Update)


    Why has the IP and Port of my server changed without any notification?


    Also started getting the database error out of nowhere, even though the master server details are listed in the config file.


    Also another config issue:


    DarknessIntensityMultiplier - Nitrado state this must be less than 1 however this is incorrect as value can be higher than 1. e.g. 2.5 will enable brighter nights


    And now we're pretty much back to square one :(


    "A unknown error occurred while saving the file."


    I'm now getting the above error, same error as we originally complained about at the start.

  • No we have to wait until they update the web admin panel before we can add the Steam64ID's for in-game admins.


    So many issues right now I'm so disappointed. Its been completely unusable since launch and I'm not alone.


    My server IP has randomly changed without notice today too, anyone care to explain why considering tickets don't get responded to?

  • I am curious to know, is this Nitrados' fault or SCUM fault? Either way, the service should not have been offered before it was ready. I am starting to regret both my purchase and looking at this company. Perhaps gportal will work. I had just heard so many good things about N, That I wanted to get their service. Now My friends and roommate and I cannot even play together.

  • ive reseted so many time reinstalled its alway the same i log in naked wit incorect stats sort this out and refund me like i asked

    Mines broken again mate, in same boat as you.


    The server settings are not even taking affect even when saved anyway so we are back to square one.


    And they changed my IP and Port without even notifying me which has really annoyed me.


    Time for a refund I'm going back the competitor.

  • Along with the issues others are having, I am unable to create a new character to replace my first one. It gives a database error.

    Yep I kept getting that, after about 5 re-installs it seemed to work but the settings are not being applied correctly, the Nitrado settings are wrong and some are missing. Still no Admin list etc.

    I've now requested a refund in my ticket.

  • Please elaborate Crypto

    I've noticed that upon a successful working server installation, the ServerSettings.ini is laid out in a specific format with settings sitting within different sections of the ServerSettings.ini.


    When we then go into general settings and click save. It looks like its messing up the ServerSettings.ini structure and sometimes also adding double entries into ServerSettings.ini and sometimes removing the master server settings from within it (this is when you get the annoying database error). I've also noticed that when the ServerSettings.ini structure is not laid out in the correct format, many of the customized server settings do not actually apply in-game and end up using default values.


    An example of what the ServerSettings.ini structure should look like (however with the addition of the master servers etc) can be found in the single player ServerSettings.ini file in this location on your PC: C:/Users/<username>/AppData/Local/SCUM/Saved/Config/WindowsNoEditor


    Nitrado need to finally put the nail in this and get the job done. With the right person and mind on the job this should be a relatively simple fix to get everyone back up and running fairly quickly, so I don't understand whats taking so long.


    I can see quite a few things wrong with Nitrado's server setup and web control panel, and I've reported many of them, but I'm getting fed up of reporting the issues and not receiving any response and the situation is not changing.


    Clearly no testing was done on Nitrado's part prior to launch of the SCUM servers. The least Nitrado can now do is fix this as a matter of urgency and provide all server owners with a free rental period for the inconvenience as simply fixing this issue will not be enough to keep us happy.