Connection Drops - Timeout - Too Often

Nitrado now has an official Discord server to bring communities, friends and other gamers together!
Join the Nitrado Community Discord now and share your experiences and knowledge with others!

Click here to go to the Discord Server!
  • Hi


    I’m getting a little annoyed with Nitrado server on XBox. I’m sick of my logins failing. Three times now I have attempted to join my server, and each time the game loads in, I see my MOTD and then I’m sent back to the server selection screen with a Host Connection to Host error.


    The server appears to be running as I can see another player on it.


    The most frustrating thing is that the games loads, and instantly I get kicked with this error. Why is this happening? I get a good ping once I’ve logged in (average of 17-20).


    If this carries on I will not be renewing my server when the subscription expires.


    It’s just happened for the fourth time in a row. This is ridiculous, and is not what I pay a subscription for. :cursing:


    This happens every day. Sometimes it’s just one connection drop, then success on second attempt. Other days it takes several attempts.


    Edit: 5th attempt and I’m in, but it took a console restart to accomplish this. I’m not very happy. Doesn't seem to happen on PS.

    Myrm


    I am currently employed as one of Emperor Palpatine's Imperial Royal Guard (Yinchorr Academy - Class of 2019).

  • I get this on Xbox too - I think it depends on the map/area and how quick it renders in. It's as if it caches from the first ttempt so normally the second attempt is quicker.


    If I crash and get kicked I have to quit the game fully for it to allow me back in. I also see quite a few people getting similar issues coming in too as I see them log in and then immediatley drop out and try to come back in again.


    It's frustrating, but manageable - however why doesn't it do it on PS4?


    Have you tried lowering the graphics quality settings from 3 to 2 - that helped me but still get it sometimes.

  • I’m not sure why it doesn’t happen on PS, or if it does, why it doesn’t do it anywhere near as often as on XBox. Yes, I’ve noticed it does seem to increase the chances of a successful log in if it’s the second or more attempt . Probably, the rendering as you say. The XBox1X, which I use, is, allegedly, the most powerful games console. Not sure why it would struggle with graphics rendering.


    Took me five attempts this evening. The most annoying thing about it is that I do get to login, see the MOTD, then take a step or two. Then the server kicks me out with the timeout error.


    Once the server settles it’s fine. Rarely have I been booted mid-game. The server needs to allow more time for logins before it declares a connection timeout perhaps.

    Myrm


    I am currently employed as one of Emperor Palpatine's Imperial Royal Guard (Yinchorr Academy - Class of 2019).