Terraria server setup

Nitrado now has an official Discord server to bring communities, friends and other gamers together!
Join the Nitrado Community Discord now and share your experiences and knowledge with others!

Click here to go to the Discord Server!
  • Hello,


    Last night, I purchased a 4 slot Nitrado server for me and some friends to play Terraria on. (This is my first time with 3rd party hosting).

    I've been trying all night to get the server running, as I wish to load a preexisting world that we had previously worked on, on to the server, but whenever I do, the server just loads up the fresh "Nitrado_terraria_world". I've tried editing the config to correct the path & world name, and have saved (all while the server was off), and then started it, with no success.


    Before any of that, I had uploaded my world to the correct path, along with its .bak file, but this seems to be ignored when I start the server? I'm sure I'm doing something wrong here, so could someone perhaps give me some pointers on how to set this up?


    Thank you in advance,


    Will

  • Try to name the world file as name.wld.wld and see if this works for you.

    Name would be your world name you chose

    Thanks for the speedy reply! I just shut down the server, renamed the actual world file as you said, and then uploaded it to the FTP, then changed the name in the config file, saved and restarted the server and it did the same thing. Upon connecting, it used the same password as was in the config, and then loaded Nitrado_terraria_server. Once this had loaded, I checked back on the config file while the server is running, and it shows me that the name had been automatically changed back to Nitrado_Terraria_Server.wld.

  • You should be able to upload the files directly from the web interface into the world locations. Did you try this then starting the server with the world name you're trying to choose?

    I did, I placed the .wld file in to the /terraria/worlds folder using an FTP connection with the winSCP software. The world is currently in the folder, with .wld.wld on the end, as above^. I'll attach a printscreen.

  • you should just have to go into the the configuration and make sure the path is correct as well.


    world=C:\SERVICES\(yourserver) _SHARE\ftproot\terraria\worlds\Nitrado_Terraria_Server.wld is the path they need to change. Just need the 'worldname'.wld part changed

    Ah I also did this. I went in to the vanilla config file, and on the following lines, I changed "Nitrado_terraria_server.wld" to the name of my world file, but upon starting the server back up, it resets it to "Nitrado_terraria_server.wld" and creates a world by that name in the worlds folder. I also saved the config file before booting the server back up.

    world=C:\SERVICES\myserver_SHARE\ftproot\terraria\worlds\Nitrado_Terraria_Server.wld

    worldname=Nitrado_Terraria_Server


    Very puzzled as to why this happens :/

  • I was also having issues a day ago when my server that has been up for about 6 days randomly had a new world created when the server restarted for the 1.4.0.4 update. It created another world with an extra .wld on it. So instead of Janitors_server.wld it was Janitors_server.wld.wld. Also the world file path changed to the one with an extra .wld. This is not what the config file was set to the day before. So i deleted the new world and change the file path back to the original world. Then when i started the server back up it created and new world with the extra .wld and changed the file path again. So i deleted the new world again that it created and just renamed my old world to have the extra .wld and now it boots up fine. I am not sure what caused this or if my solution is a real fix but i have restated multiple times to test and it loads up the correct world now.


    If you are in the general settings menu on the web interface i would make sure you have expert mode on. Only do this while the server is stopped. Make you do any changes while the server is stopped or else nothing will save and it will all revert back. Once expert mode is on go to the Expert Settings tab which will bring up the vanilla.config file, then make sure the world path end and the worldname are identical except in the world path part make sure it has .wld.wld on the end. Then navigate to file browser and open the vanilla.config again and make sure all the lines are the same as the other expert settings vanilla config file. Changing one should change the other but just make there is no difference. Again make sure the server is shut down while any changes are being made and only restart once you have saved everything.

  • Drakexz

    Added the Label Terraria