Cannot Connect to ECO Server - UPnP device cannot be found

Dear forum members,
for some time now we have been creating and maintaining new ways to help game server admins with questions and problems as quickly as possible, e.g. our Guides section and the Nitrado Community Discord.

Therefore, we inform you that the Nitrado Forum will be closed on March 31, 2023. We are consolidating our community support to our Discord channel, which is faster and more efficient. We have also seen incredible growth in our community due to the hard work of our moderators and our bots. We are confident that this move will ensure that we provide the best support possible for our users.

Thank you to all members for your continued use of the forum!

Assistance with all questions concerning your Nitrado service can now be found in these spots:
Community Discord:
Guides section:
Support Wizard:
  • Hello,

    I rented a ECO server around 14 days ago. I used an existing world i had just started playing on with friends. This was working great until recently. Two days ago on the 14th or 13th the server suddenly became unreachable. Any in game connection would timeout consistently. Any attempt to access the website on port 4001 would also fail with a timeout.

    I checked at first if the server is actually reachable and indeed if i use a ping command inside a console i get a response. So the machine is up and running. From the dashboard i see the server is running fine with around 500mb RAM usage. CPU usage is at zero with spikes here and there.

    I tried restarting the server but that did not solve the issue. Interestingly when i shutdown the server a message appeared in the log:

    1. [22:39:24.070] [26] [ Info] [Eco] No UPnP device with public ip was found.

    I use the default configuration that Nitrado provides. This is the content:

    I tried setting UPnPEnabled to false. But i still could not connect to the server. The error went away however. The complete startup log is attached.

    Any pointers to help debug and solve this problem?