GameUserSettings.ini settings overriden after Easter Event

Dear forum members,
for some time now we have been creating and maintaining new ways to help game server admins with questions and problems as quickly as possible, e.g. our Guides section and the Nitrado Community Discord.

Therefore, we inform you that the Nitrado Forum will be closed on March 31, 2023. We are consolidating our community support to our Discord channel, which is faster and more efficient. We have also seen incredible growth in our community due to the hard work of our moderators and our bots. We are confident that this move will ensure that we provide the best support possible for our users.

Thank you to all members for your continued use of the forum!

Assistance with all questions concerning your Nitrado service can now be found in these spots:
Community Discord:
Guides section:
Support Wizard:
  • Hello to everybody!

    After the update 310.11 (Easter event) my server GameUserSettings.ini got automatically edited adding the following code at end:

    1. [/Game/PrimalEarth/CoreBlueprints/TestGameMode.TestGameMode_C]
    2. bIgnoreStructuresPreventionVolumes=True
    3. PreventDinoTameClassNames=Easter
    4. CropGrowthSpeedMultiplier=20.000000
    5. MatingIntervalMultiplier=0.007500
    6. EggHatchSpeedMultiplier=180.000000
    7. BabyMatureSpeedMultiplier=700.000000
    8. BabyCuddleIntervalMultiplier=0.008500
    9. HairGrowthSpeedMultiplier=0.700000
    10. UseCorpseLifeSpanMultiplier=6.000000

    I dont know if was an ARK update modification or an Nitrado modification, but I haven't done it.

    It's causing my server rates (already boosted) get even more boosted.

    My original rates:

    1. TamingSpeedMultiplier=20.0
    2. MatingIntervalMultiplier=0.05
    3. EggHatchSpeedMultiplier=20.0
    4. BabyMatureSpeedMultiplier=20.0
    5. BabyCuddleIntervalMultiplier=0.05

    I spent whole day figuring out what's happening and why, but to be honest nothing makes sense to me...

    For some reason seems that the settings below [/Game/PrimalEarth/CoreBlueprints/TestGameMode.TestGameMode_C] are overriding the Game.ini settings previously defined. The values assigned seems to be some multiplicative calc of my defined rates with the event rates (x4), but anyway no makes sense.

    1. TamingSpeedMultiplier is getting affected too, even when its not defined in [/Game/PrimalEarth/CoreBlueprints/TestGameMode.TestGameMode_C]. I had it x20 and now it's x50.
    2. MatingIntervalMultiplier I don't know what math is used, but no make sense to me.
    3. EggHatchSpeedMultiplier I don't know what math is used, but no make sense to me.
    4. BabyMatureSpeedMultiplier I don't know what math is used, but no make sense to me.
    5. BabyCuddleIntervalMultiplier I don't know what math is used, but no make sense to me.
    6. bIgnoreStructuresPreventionVolumes, CropGrowthSpeedMultiplier, HairGrowthSpeedMultiplier and UseCorpseLifeSpanMultiplier WTF... the event not even makes any reference to them.

    This is something that I dont desire so:

    - I tried to remove them from GameUserSettings.ini, restart server, and still exactly the same rates in effect...

    - I tried to restore to default settings on webpanel and configuring all again from scratch, and the settings I removed previously from [/Game/PrimalEarth/CoreBlueprints/TestGameMode.TestGameMode_C] didn't got writen again, but like before same rates in effect. So isn't an ARK update modification?

    The only way to set my previous rates seems to be edit the original rates from Game.ini, but since I don't know what math is exactly used its hard to adjust them.

    I figured out to bring back the previous TamingSpeedMultiplier setting it to 8.0 * 2.5 = 20. Why 2.5? I don't know, but sems to be multiplying with this. But Im not able to figure out the another settings.

    Im the only one suffering this or caring about it?

    Any information, advice or help is welcome...

    Thanks in advance!