Unable to join My server after easter Update

Nitrado now has an official Discord server to bring communities, friends and other gamers together!
Join the Nitrado Community Discord now and share your experiences and knowledge with others!

Click here to go to the Discord Server!
  • Hi All,

    I changed maps yesterday evening (EST TIME) and we were all ready to go. Then Nitrado did the update and now when we try to join the server it says "Unable to query server info". I've done the whole winsock thing. I've validated My game files. I've uninstalled Ark and reinstalled Ark. I've turned off My firewalls and have tried to direct connect from the UI on the server. When I try to direct connect it says "server is not responding". It is also not showing up in My favorites.

    This has been happening since around 11:30 PM EST last night.

    Please help. Any and all help is appreciated.

  • Yup, I had to make a support ticket. I was getting a "hang detected" on their end. Took about two hours or so to resolve it.

    I am still not sure what caused the issue in the first place though.