Can't Place any Structures (Primitive+)

Nitrado now has an official Discord server to bring communities, friends and other gamers together!
Join the Nitrado Community Discord now and share your experiences and knowledge with others!

Click here to go to the Discord Server!
  • So I own a server for me and all my buddies (Xbox) to play on, and this is our third server with Nitrado. All has been great, but recently we decided to switch our server from the base game on Valguero to Primitive+ on Ragnorak. Everything has been working flawlessly besides that I, and only me, can't place any sort of structure. The structure highlights as green and makes a sound when I click to place, but it just fades away and isn't placed. Building works fine for everyone else, but for some reason it doesn't allow me. I'm aware of a thread with a very similar issue and I've tried nearly everything the other server owner tried but for me it worked to no avail as well. I'm the main builder so this has seriously put progressing for us to a fault. This issue has only occurred on Primitive+ for us, and doesn't occur on any other server or singleplayer. This appears to definitely be a Nitrado issue. There isn't any clear and definite answer I can find on this.

  • Not sure how it would be a Nitrado issue when it only affects you and not others.

    Sounds more like a misconfig on the server ini or client or your profile.

    Check your server ini file and see if any duplicates. Because that could cause issues.

    You could try a restore from the most recent back up and see if that works. Note if you do and it fails, the one you are using now will not exist. If you were PC server, you could back it up via ftp.

    Its harder to suggest some possible fixes for consoles. For PC I would just say make a copy of your player profile, then delete it. Try connecting then and see if that works. If it had, that means your profile was corrupted. And I can not suggest a reinstall and test that being you dont have FTP cause a reinstall deletes your backups.

    I would say if a reboot didnt fix it, contacting Nitrado Support and see what they suggest.

    Support |

    Do note as well, Prim+ is no longer supported by WC. they have this posted in their Wiki.


  • There seems to be an issue with recent patches where structures from any mod (P+, S+, etc.) cannot be placed in the world, only vanilla Ark structures can be placed. Wildcard is aware of it. Word is that having both client AND server on their latest patches may fix it, but Nitrado doesn't seem to have pushed server 304.44 yet.