New Server - How to know if current version of Forge (1.15.1) is compatible with Nitrado

Nitrado now has an official Discord server to bring communities, friends and other gamers together!
Join the Nitrado Community Discord now and share your experiences and knowledge with others!

Click here to go to the Discord Server!
  • Hey everyone, new to all this.

    So, I'm following:
    https://wiki.nitrado.net/en/upload_own_minecraft_modpack


    I have everything uploaded through Filezilla hopefully correct. After pasting the 4 mods I want to use, tested the minecraft_server.jar on my end and it worked fine. Currently though, I cannot seem to start the server. I keep seeing the error message:
    :!:Currently there are some information missing to show this page. This happens when the gameserver is not fully started.


    Any ideas how to troubleshoot this? The version of Forge that I downloaded was the newest version at the time of this posting.

  • lmao, how do I edit my post? I realized I had a Bukkit install instead of a Forge. Reinstalled the server as a Forge 1.14 from the Nitrado options, then just followed the wiki entry to replace all the files with the newest file.


    Running into a new problem though: Friend and I cannot connect to the server.

    + We both have the same version of Forge Clients installed that was used to create the server files
    + Same mods are added to the client's mod folder (even tried without)

    + Both our accounts were added to the whitelist, and server restarted after added.

    + Nitrado Server Check reads: Congratulations! No errors or necessary optimizations were detected!

    + Nitrado Console doesn't show friend or I pinging the server.

    + Our clients are not crashing, only showing "Failed to Connect to the Server"

    + This is a brand new server on a new account. Friend and I have connected to other non-Forge Minecraft Nitrado servers before. We were recommended to go through Nitrado.


    Any ideas?


    If it matters:

    Minecraft Server 1.15.1

    Forge v.1.15.1-30.0.24 (from 4 Jan 2020)

    Aquaculture 1.15.1-2.0.6

    engineersdecor 1.15.1-1.0.18-b2

    FallingTree 1.15.1-2.0.1+11

    u Team Core 1.15.1-2.9.3.145

    useful Backpacks 1.15.1-1.8.3.51


    Testing all these clientside before FTP-transferring worked.

  • Oh, just realized I posted this in the Minecraft/Bukkit thread section. My bad, can't change it.


    Doing so more tests in the meantime. Deleted everything off the server and reinstalled a Forge 1.14 from Nitrado's menu selection. Friend is able to join, and I see him in config. However, there's also a problem:


    [K[17:24:02.653] [Server thread/INFO] [minecraft/DedicatedServer]: [0;33;1mVikifox joined the game[39;0m[39;0m

    >

    [K[17:24:05.073] [Server thread/WARN] [minecraft/MinecraftServer]: Can't keep up! Is the server overloaded? Running 2023ms or 40 ticks behind

    >

    [K[17:25:56.112] [Server thread/INFO] [minecraft/DedicatedServer]: Vikifox has made the advancement [0;32;1m[Stone Age][39;0m[39;0m

    >

    [K[17:27:45.154] [Server thread/INFO] [minecraft/DedicatedServer]: Vikifox has made the advancement [0;32;1m[Getting an Upgrade][39;0m[39;0m


    Is that normal? When choosing the RAM selection on buying a server, I chose the default option which said it was suitable for most Minecraft servers. No mods added atm. Would that have anything to do with being unable to connect before?

  • New Update:

    Can now log into the 1.15.1 Forge server. No idea how or why, but I just kept wiping the server, re-adding the files, and trying.


    I think the Nitrado wiki might be wrong. It instructs to delete everything in the server files, but I left the items that were not getting transferred over. Specifically:


    • banned-ips.txt
    • banned-players.txt
    • ops.txt
    • server.properties.txt
    • white-list.txt/white-list.json (depends on your Minecraft version)


    https://wiki.nitrado.net/en/upload_own_minecraft_modpack



    _______


    :!:New error though. Friends and I are both on real, paid Minecraft accounts, but we keep receiving this message when logging in. Something about being on a Demo mode. Any idea why?


    Also, apologies to whatever forum mod reads this. Should be in the other Minecraft subforum. Can't edit or delete my original posts.

  • Please take a look at the Server Live console and restart the server.

    Look for the line that reads: ": Start Minecraft server at *: 25565"

    If the port is 25565, everything is fine.

    In some cases, the port was changed even though it was not set.

    As a result, the server was in demo-mode after joining.

    So far it could be fixed by reinstalling the server!

    If this is not the case, please contact support!

    MfG Conan ;)


    Nitrado: Conan

    Minecraft: Conan

    Discord: Conan#3864


    Fragen u. Antworten rund um Minecraftserver (Vanilla/Forge-Modpack/Bukkit-Spigot-Paper)

    Nicht alles aber vieles! Bisher wurde noch sogut wie jeder Server zum starten gebracht!

    Wollte nur mal sagen:

    "Ihr könnt mich gern in Discord hinzufügen, aber Antworten gibts erst abends (am WE auch mal ehr ^^) weil ich auch Arbeiten muss!"

    Daher bleibt mir für`s Forum nur noch wenig Zeit!


    -- Minecraft only --

  • Hey, I think I have the same problem with MC 1.14.4 and Forge 28.1.109. Server starts up and I connect, but when I do I get the message that I am in demo mode, even though I am using a legit minecraft account and all. Going into Singleplayer everthing works as expected.

    If the port is 25565, everything is fine.

    In some cases, the port was changed even though it was not set.

    As a result, the server was in demo-mode after joining.

    So far it could be fixed by reinstalling the server!


    Can you elaborate? I tried to set the port to 25565 via server.properties, but when I restart the server it always starts on 25765, and the changes I made to server.properties are gone.


    What do you mean by "fixed by reinstalling" the server?