Primalgamedata_bp crashing on second server/ removing the server password temp fix

  • Hello Nitrado Community, I am having a bit of trouble with my server(second server only). friend logs out on the second server and I log out on the main server. So when i have the server password on i can connect to the main server. Main server is fine no issues but flying fish on a restart. now on the second server friend tries to login puts in everything correctly and when the game is loading Primegamedata_bp he fails to connect. now the only thing that fixes this issue as of now is removing the server password then he is able to join.


    Thing I have tried on Server settings as of now

    *Checking and not checking able to spawn on home server. Checked as of now (did not fill in spawns on the map editor/working on now).

    *Removing server password (fixes the issue he has when joining) Could this be a server side issue? can i not turn off the password of my second server? or is this my fault in some sort of setting on the map editor?(double checking/working on now).


    Any thoughts on what my mistake is?

  • Okay I believe i have solved my own problem. so what i did was:

    1. go to Nitrado, click the gear on the main server.

    2. click on configure your atlas Download your config file.

    3. Open Server grid editor on a pc.

    4. Open Projects, open, then downloads( or where you have your downloads going).

    5. Open cluster_config file

    6. for the grid have the box check marked for server info.

    7. ip, port, and gameport must be filled in(for B1 all grids are different)

    ip: 37.10.126.133

    port: 57561

    gameport: 5761

    *if your having this issue in another grid you can just load one of the sample grids that comes with the Server Grid Editor and copy the information.

    8. Save

    9. upload new saved cluster config file

    10. Restart Server

  • Thank you for posting your fix and work around. It's usually due to having the password on. If you removed the password and restart all servers it will usually let him back on and work fine after that.

    i just think the second server doesn't need a password? wouldn't that mean that the server is asking for the same password twice? plus it is an expansion server not gunna show on the server look up anyways unless you know the IP or I make spawnable areas which I don't want? I do believe that removing the password for Expansion servers would fix the issue. and keep only passwords for main servers. hey i would beta test this in a heart beat. whats the worst that could happen.

  • I have finally figured it out a fix to keep my server password. So here we go!


    step 1. download your cluster config file at Nitrado, to do this click the gear on the main server.

    step 2. At a PC have your server grid editor opened, open the cluster config file you downloaded from the server.

    Step 3. set B1 as a home server as well as your main server (both servers will stay as home server).

    Step 4. using grid editor set spawns on islands you wish people to first spawn at (0,1,2,3) , both of my servers have 2 spawning points on each map. or you may check off AutoGenerateIslandSpawnRegions in the general tab when adjusting your server settings at Nitrado website.

    Step 5. Save you cluster config file, and upload it to your server.

    step 6. Restart your server.