Cannot retrieve server information.

Nitrado now has an official Discord server to bring communities, friends and other gamers together!
Join the Nitrado Community Discord now and share your experiences and knowledge with others!

Click here to go to the Discord Server!
  • Hello all! I have a 4 player server. When I try to add a seed map to my server it stops showing up on the server list and I get "Cannot retrieve server information" when trying to connect via the IP option. I also tried just random and set the world size to 8192 and had the same issue. I tried adding a 8k map seed and setting the map size to 4k to see if that would work and got the same results....however, I am new to 7 Days so I am not even sure that it's possible to run an 8k seed as a 4k map size. ;( ;(;( Can anyone help me please? Thank you very, very much for your time!

  • Question is:
    Are you just putting a seed in the serverconfig.xml or do you want to add a pregenerated map ?

    If serverconfig.xml -> Remember to change GameWorld from "Navezgane" to "RWG"

    (I think you can add a 4k seed to any mapsize, but it may get you a complete other map)

    If you want to use a pregen map, you have to insert the the World-File to ./Data/Worlds/

    It could also be, that you just did not wait long enough for the Server to generate the new Map,

    this can take some Time (calculate with 5 to 20 mins, depending on Map size and the things generated (roads etc.)

  • Aunt Edit told me it could be much simpler, Nitrado got some Problem with the 7DTD Servers.
    At least for me it was solved by Support today.

    Maybe they got rid of the Problems.

    It could help to install the game completely new. [ server dashboard -> reinstall]

    If you save your Saves and Mods folder and backup the serverconfig .xml you can reupload them after reinstall is finished.

    (be aware that the game versions have to match)

    ( you may have to adjust the server IP and Port within the serverconfig.xml )