WHEN will MOD support be ready?

Become part of a great team that has nothing less as its goal than to be the world's best game server provider. Keep facing new, challenging and exciting tasks at a company that values your opinion.


open positions @ Nitrado
  • Please reply with something beyond "we are working on it". It is a crucial feature of private servers, and as you can tell from both your own (old) forums and virtually every other forum, Nitrado DOES NOT have working mod support (even for official mods that are downloaded from the Steam workshop).

  • Please reply with something beyond "we are working on it". It is a crucial feature of private servers, and as you can tell from both your own (old) forums and virtually every other forum, Nitrado DOES NOT have working mod support (even for official mods that are downloaded from the Steam workshop).

    How to add mods in step one.

    If the mod is already available on steam (Steam Community :: ATLAS 2) you have to download the current cluster config and change

    “ModIDs”:"" to a comma separated list of mods for example “ModIDs”:“1652044230,1648830674” and then reupload the file. Now you can restart the whole cluster and everything happens in the background.

    To remove mods you can remove them from the ModIds list and restart the cluster again. The mods are automatically removed.


    Edit: We've added this information to our Wiki now; https://wiki.nitrado.net/en/installing_mods_on_an_atlas_server Thank you for bringing it up!

  • We have tried everything under the sun to get mods to work reliably on our cluster. When following your suggested json update, the following happens: the mod SOMETIMES works on one server, but never the entire cluster (no idea why). NOTE: we are only trying to use official steam workshop mods.


    We have also tried the more traditional approach of updating the json AND uploading the mod file/directory to the same on every server we have... also doesn't work.


    We have spoken with several mod authors about how to get stuff working on Nitrado, and they have speculated about many reasons why it does not work on your setup while it works fine for people using different hosting providers. Bottom line, this likely has little to do with being EA, and more to do with how you have the servers hosted and mod support implemented?


    UPDATE: the main mod we REALLY want to have active is: Custom Item Stacks (1629667379 )

  • Yes, I would like to be able to install them on the interface. I've tried to install them the way others have suggested in the past and all that has done was set the server in an online/offline loop endlessly. Other games on Nitrado have support to install mods through the web interface. My server expires today and I'd like to restart it but I will wait until Mod Support/Mod Installation on the web interface is possible. I haven't even opened my server up (or increased player limits) while waiting for this to happen. Servers hosted outside of Nitrado seem to have no issues with installing mods.

    I hope Nitrado does soon! I will keep checking back periodically to see if this ever happens. Thanks, thanks!

  • So, before I write anything else, I want to be clear, I fully understand the risks that come with EA and using mods. Have been doing it for a few year now, from lightly modded to not-so-lightly modded (size and number). :D Only ever lost one server, and that was more my fault that the mod and the Ark update that made things go poof.


    Furthermore, this is not a gripe, just some of my observations and experiences, and probably some opinions/guesses. Take them for what you want.



    The issue, at least for me, isn't adding or removing mods. I can do that without much issue via the .json.


    It is when a mod updates. After that, all bets are off.


    Issues I run into after a mod update include:


    - Mod cabinets and other objects in the game go away.

    - Learned mod skills become unlearned and/or cannot be learned

    - Some mod engrams from a learned skill are not accessible/usable

    - Mod objects become unstable and cause disconnects when accessing
    - Mod related commands do not work; such as to access an admin panel

    - One or more servers become unstable; constant reloads, cannot query, timeout during connect. etc.


    These are usually symptoms of a mod that has not fully downloaded or installed correctly; of course, sometimes an update to the core game will break stuff.


    And, to be clear, at the first sign of trouble, I don't throw up my hands and blame anyone. I try to work out the issues, including respecing the character, destroying and rebuilding mod related objects, checking for updates/info from the mod(s) Steam page, reviewing the patch notes from any updates to the game, checking the forums, and even giving the server a restart. And, of course, on the client side, un-subscribing and re-subscribing to the mod(s).


    Sometimes, I just ignore the issue and play on; minor content I can live without.


    However, sometime, the only thing that seems to fix the issue is to restore from a backup, which can result in a full day(or more) rollback, and takes a bit of time to complete. And, with multiple servers, the backups are not synchronized, so it can get tricky.


    As far as I can tell, there is no way to do a rollback like you can do in Ark, using one of the many saves. Also, there does not appear to be a way to force a mod to re-update. At least with the ability to do saves and short rollbacks, you could save(save point), stop, drop the mod, restart, stop, re-add the mod, start, test, stop, and restart for the saved point(or further back in case of a bad mod update that resulted in lost objects). This does assume that upon dropping and re-adding the mod, the game will re-download and re-install the mod.


    Even being able to setup a more aggressive backup schedule(and keep it synced between the servers) and/or being able to take your own backup would take some of the sting out of doing a restore from backup.


    Currently, I am not inviting anyone to the servers because I cannot guarantee enough stability; I would never guarantee 100%, but I have enough issues and restores from backup that I would not want to subject players to that experience.

  • I wish I was one of those lucky few for whom the json mod installation process just worked... it doesn't, and nor do the other ways people have suggested. Given that many other hosted servers (non-Nitrado) have mods working fine, I hope they are taking a serious look at whatever they are doing here, and get it fixed asap. You will notice that they STILL have not given an actual timeline for when they can give us real mod support?

  • When I update my .json, I usually use the Server Grid Editor; GitHub - GrapeshotGames/ServerGridEditor: ServerGridEditor for Atlas. Nitrado also has a short tutorial here: https://wiki.nitrado.net/en/server_grid_editor. I just unzip the Server Grid Editor into my main Atlas folder; /ServerGridEditor-master.


    If you are using the default 2X2, it is included with Server Grid Editor download, along with a couple of other types, including the 1. Or, you can download your current one and put it into the /projects sub-directory of the Server Grid Editor. I usually make a copy before I edit...just in case.


    After you open in the editor, just click Project, then Edit, and in the modal, there will be a spot for Mod IDs; just type in the list you want to use, and then click the Edit button at the bottom (basically it is the OK or Save button).


    Then click Project and Save.


    At the bottom of the Editor is a bunch of options, unclick Show Discovery Zone Info; otherwise, the next step will glitch. If you are doing customer islands and plan to upload the maps, you may also want to unclick Show Island Names.


    Lastly, I click Export, and then All. This will create the .json you will want to upload, and plus mag images(only need to upload those if you change the islands). It will ask you where to save them; I created a sub-directory in the Server Grid Editor called /Export.



    To upload, I do the following:

    • I stop all of the servers
      • I am not sure if this is necessary, but given its tendency to overwrite whatever you upload for other files, if the server is still active, I figure better safe than sorry.
    • Once the server(s) has been down for a few minutes, I goto Configure Your Atlas and upload the .json from my /Export directory (don't use the .ServerOnly.json). Make sure to wait for the pop up that tells you the upload/update is complete.
      • And, don't worry about the name, as it will copy to where it wants the .json. For example, for every file I edit, I add a version number on it: My Map - V3.json, My Map - V4.json, My Map - V5.json, etc. I just pick the one I want.
    • Then, I restart the servers and wait (usually with a small prayer). If you are doing a lot of mods, this can take a bit.


    You may also want to consider starting with just one mod, making sure it all starts and works okay, and then add another mod a later (you may even want to wait until you have a backup).



    One item to note about the Server Grid Editor, if you use the Save feature and save your grid under a new name, and that is the name you want to continue work with, once the save is complete, you will need to go and open that file; the Server Grid Editor will still think your are in the file you originally opened.


    Also, if you decide to build your own custom map, I would start with one of the maps that is included, as they have the default Server Templates, and include Polar, Tundra, Temperate, Tropical, Equatorial, and Desert.



    Lastly, with the Customer Stacks mod, I would be careful. I had it sink a ship early on in its development, as it does a lot of recalcs when running and has done a lot of coding to deal with server start ups, changing maps, etc. I use it only for stack sizes and disable the weight reductions. Also, sometimes, especially after reboots, the stacking needs a nudge, as the stacking does not always work; I usually have to bring the items into the character inventory to get the stacking to work. This is not a major issue, just a minor thing you have to watch, especially for stacking food, which is one of the main benefits.


    For weight management, I use the Cargo Box mod. The Cargo box has 4 models (2 for land and 2 for ships) and you can used the Cargo Box mod directly on the cargo saddle (which is great). However, the Resource version of the Cargo box does not work like a resource box(except you can only dump resources in it), so you will still need a regular resource box (otherwise, you will lose your crew if you rely on the resource box to pay them).


    I usually make up for Resource box by using the Atlas Better Stuff mod; it has a Resource Box with weight reduction. However, it is a big mod and one that I have had issues with after updates. Also, the mod author is splitting that mod in the near future(Apr 1) and dropping a few things, so you may want to wait for that to occur before checking out/using their mods. They are also recommending to use the Atlas Plus mod, which I have not tried yet(but plan too), so cannot advise on that yet.

  • Jerryn - thanks for the detailed suggestion. Know that we have done exactly what you outline, along with many other suggested work-arounds. The problem for us is that is still will not work properly nor consistently across all grids. You would think it should, but it doesn't. Worse, sometimes the same solution will end up with different results (i.e. one time it works on 1 grid, another time the SAME method doesn't work on any grid).

  • Jerryn - thanks for the detailed suggestion. Know that we have done exactly what you outline, along with many other suggested work-arounds. The problem for us is that is still will not work properly nor consistently across all grids. You would think it should, but it doesn't. Worse, sometimes the same solution will end up with different results (i.e. one time it works on 1 grid, another time the SAME method doesn't work on any grid).

    Yeah, this is true.


    I just added the Atlas Plus mod yesterday, and one of my servers refused to start. Had go to an older back up to get it to recover. I will probably let the other servers expire and experiment with the one for a while, until I feel like the stability is there.

  • At this time, MODs are able to add to the JSON, and update per the Wiki.

    As for having the mod banner like with other games, it is still being worked on with no ETA. Nitrado will post an update when available.

    That is all the information I have at this time.

    Thank you.

  • DOAGEN you guys keep suggesting the JSON method, despite having shown you repeatedly it DOES NOT WORK CONSISTENTLY OR AT ALL. And then you also say no ETA on when you will be adding real / fully tested mod support. I am getting the sense that Atlas may not be a priority? An honest answer would be great, so if we should start looking for other hosting providers we can do so. If you are not fully committed to Atlas that is fine, but please stop stringing us along. Our community really wants to add mods to our cluster, but I cannot at the moment.

  • Well, I'm honestly telling you what I know. ;)

    I am only a moderator. I can also tell you others I know of running Atlas have mods running per the wiki and seem to be working fine. (i run my own community- and connected to many others). Personally I do not run mods on EA games.


    Every game and customer is a priority to Nitrado. They are working on it.

    I always ask about the modIDs being added to the interface. It will come.

  • I hear what you are saying... but it gets pretty frustrating. See below to recap:

    ME: I have tried A, B, and C to get mods working on our cluster, and none of them work consistently if at all. When will u get official MOD support ready??

    NITRADO (or rep): Method A is the way to get MODs working, for some others this seems to work

    ME: did you not read above?

    NITRADO: no ETA on when we will actually support MODs. You are playing an EA game, so u cant really expect us to be ready.... well.... except for billing of course.


    Just because method A may have worked for a few people (likely on a 1x1 server or 1 month ago for a week), and it took really NO effort on your part to make that possible, it does NOT mean this is a wiki-worthy solution for how to get MODs working on Nitrado!

  • Ich habe den Custom Item Stack Mod hinzugefügt ModId:.1629667379 rein gemacht Server gestartet so wie es aussieht funktioniert es trotzdem nicht fliege aus dem Spiel und Server ist wider im Neustart.

    Ich werde es mal mit einen einfachen Mod versuchen ob es damit Funktioniert. Mfg:.SoulHunter2701



    I have added the custom item Stack Mod ModId: .1629667379 made it pure server as it looks like it still does not fly out of the game and server is resisting reboot.

    I'll try it with a simple mod if it works with it. Mfg: .SoulHunter2701


    Bs:.Habe dann den Eco's Rpg Decor hinzugefügt und er hatte direct Funktioniert :)

  • Will do that shortly.... going to stop the cluster, update every one of the 9 server's base setting with our most wanted MOD ID, then restart the cluster and hope all goes well

    ok just noticed you only have the mod field on the main server... about to restart the cluster and we will see

    hope the mod field gets perpetuated across all servers then, even when each server has its own unique settings in the CP

    RESULT SO FAR: mod is NOT working on all servers (not too surprising given comment above)…. will go test it on main / home server

    The mod is also NOT WORKING on main / home server.


    The mod we are (and have been forever) trying to run is Custom Item Stacks (1629667379 ) an official steam workshop mod

    Ok I have now stopped & restarted the cluster several times, and the MOD is definitely not working.


    I have verified that the mod id is appearing in all the server gus.ini files (I was worried it would not given that only the main server control panel had the mod field), but it still does not actually work.


    If it helps you Nitrado, below is our cluster setup (each server has custom settings via the control panel):

    3x3 PVPVE

    A1, A2, B2, C2 are all PVE

    All 5 other grids are PVP

    PVP grids by default have slightly higher gather & exp settings

    B3 and C1 have even higher rates as they are polar and desert climates as well