Connection issues to new server

Dear forum members,
for some time now we have been creating and maintaining new ways to help game server admins with questions and problems as quickly as possible, e.g. our Guides section and the Nitrado Community Discord.

Therefore, we inform you that the Nitrado Forum will be closed on March 31, 2023. We are consolidating our community support to our Discord channel, which is faster and more efficient. We have also seen incredible growth in our community due to the hard work of our moderators and our bots. We are confident that this move will ensure that we provide the best support possible for our users.

Thank you to all members for your continued use of the forum!

Assistance with all questions concerning your Nitrado service can now be found in these spots:
Community Discord:
Guides section:
Support Wizard:
  • Howdy,

    I'm having troubles connecting to my server...keep getting errors like "lost/timedout pending connection to host" (which does an infinite loop) and "unable to query server info for invite" ...can't seem to find a workaround for either of these issues. Help would be much appreciated.

  • Normal typical stuff- check for updates, any mods, actually using correct IP address, tried forcestop, rebooting.

    Can anyone connect? If others can and some cant, that would be more than likely client side. I would still reboot the server.

    If that all fails, create a ticket with Nitrado Support-

    Support |

  • I've checked for updates; not working after. Mods: i have a few, but i took them off and tried without them, no avail. I've tried restarting more than a couple times since purchasing the server about 8 hours ago, so nothing there. IP is correct, according to the wiki there (adding 1 to the end like it says). I've also tried a forcestop twice, still having problems. I'll see if a friend can connect...if he can, and I can't what would you recommend I do? Also, thanks a ton for the quick respond, I really appreciate it.