Minecraft gameserver stuck on restart loop

Dear forum members,
for some time now we have been creating and maintaining new ways to help game server admins with questions and problems as quickly as possible, e.g. our Guides section and the Nitrado Community Discord.

Therefore, we inform you that the Nitrado Forum will be closed on March 31, 2023. We are consolidating our community support to our Discord channel, which is faster and more efficient. We have also seen incredible growth in our community due to the hard work of our moderators and our bots. We are confident that this move will ensure that we provide the best support possible for our users.

Thank you to all members for your continued use of the forum!

Assistance with all questions concerning your Nitrado service can now be found in these spots:
Community Discord: https://discord.gg/nitrado
Guides section: https://server.nitrado.net/guides
Support Wizard: https://support.nitrado.net
  • Hi. After my server got installed, me and 5 of my friends joined the server. And even tho it had some lag (Which was expected cause the server has 1gb of ram), it was playable. The problem is that, after a couple of hours of playtime, the server just crashed. I ignore it and I go ahead and install some datapacks that I had forgot to install, try to restart the server and it wasn't starting up. The console was empty. After a while, I clicked on the button "Force Start Server" that appeared and it didn't do anything. I tried to remove the datapacks but to no avail. Then i went to sleep and left the server to try to restart. I woke up and it was open with some out of memory errors and event loop errors. I ignored them and tried to join to the server and it worked. But I needed to install the datapacks to the server because there are necessary for the server so I shut it down and installed them again and now i have the exact same issue. I don't know if there is a fix but it is important because i don't want to spend money for a server that cannot start.

  • EDIT: I figured it out! If anyone has a similar issue with bukkit 1.14. , just force the server to stop, Start it up and just wait for about 15 to 20 minutes and it should start up normally! If this doesn't work than either post a thread in this support forum or send a support ticket to the guys at nitrado. You could also talk with them on phone or skype via call if nothing else works! I hope that this thread can help you if you have a similar issue!