Trader Mod Not working properly

Nitrado now has an official Discord server to bring communities, friends and other gamers together!
Join the Nitrado Community Discord now and share your experiences and knowledge with others!

Click here to go to the Discord Server!
  • So, my issue is that when I try to create a Black Market I can not get more than one of the markets to spawn on the SurvivorM object.


    MOD: Trader by Dr. Jones


    I have created a Black Market, I have the Weapons trader made as #6 TraderMarker. It works perfectly.


    I made #7 (Raid/Base) and #8 (Drugs) and they do not work at all. The SurvivorM object is in place in the correct Coords, but the UI for the trader is nowhere to be found even though it has the same coords as the SurvivorM Object.


    This is my layout in the TraderObjects.txt for BlackMarket

    //Krona:


    <TraderMarker> 6

    <TraderMarkerPosition> 1396.54, 305.507, 9279.28

    <TraderSafezone> 0


    <TraderMarker> 7

    <TraderMarkerPosition> 1410.13, 307.267, 9269.63

    <TraderSafezone> 0


    <TraderMarker> 8

    <TraderMarkerPosition> 1402.84, 306.671, 9282.97

    <TraderSafezone> 0


    //Krona:


    <Object> SurvivorM_Seth

    <ObjectPosition> 1396.54, 305.507, 9279.28

    <ObjectOrientation> 152, 0, 0

    <ObjectAttachment> Bandana_Blackpattern

    <ObjectAttachment> HighCapacityVest_Olive

    <ObjectAttachment> USMCJacket_Woodland

    <ObjectAttachment> USMCPants_Woodland

    <ObjectAttachment> TTSKOBoots

    <ObjectAttachment> MilitaryBoots_Black


    <Object> SurvivorM_Jose

    <ObjectPosition> 1410.13, 307.267, 9269.63

    <ObjectOrientation> -25.8798, 0, 0

    <ObjectAttachment> Bandana_Blackpattern

    <ObjectAttachment> HighCapacityVest_Olive

    <ObjectAttachment> USMCJacket_Woodland

    <ObjectAttachment> USMCPants_Woodland

    <ObjectAttachment> TTSKOBoots

    <ObjectAttachment> MilitaryBoots_Black



    <Object> SurvivorM_Elias

    <ObjectPosition> 1402.84, 306.671, 9282.97

    <ObjectOrientation> -167.94, 0, 0

    <ObjectAttachment> Bandana_Blackpattern

    <ObjectAttachment> HighCapacityVest_Olive

    <ObjectAttachment> USMCJacket_Woodland

    <ObjectAttachment> USMCPants_Woodland

    <ObjectAttachment> TTSKOBoots

    <ObjectAttachment> MilitaryBoots_Black

    <ObjectAttachment> AviatorGlasses



    as I stated above the trader 6 works perfectly.

    I have even deleted #7 and #8 in the TraderConfig.txt file and rewrote them with the right tags.

    EX:

    <Trader> Raid Tools

    <Category> Supplies

    <Trader> Drugs

    <Category> Bricks


    Has anyone else had this problem and is there a fix that I'm over looking? I'm losing my mind.