StaticObj buildings disappearing

Dear forum members,
for some time now we have been creating and maintaining new ways to help game server admins with questions and problems as quickly as possible, e.g. our Guides section and the Nitrado Community Discord.

Therefore, we inform you that the Nitrado Forum will be closed on March 31, 2023. We are consolidating our community support to our Discord channel, which is faster and more efficient. We have also seen incredible growth in our community due to the hard work of our moderators and our bots. We are confident that this move will ensure that we provide the best support possible for our users.

Thank you to all members for your continued use of the forum!

Assistance with all questions concerning your Nitrado service can now be found in these spots:
Community Discord:
Guides section:
Support Wizard:
  • Hello, I hope someone has solved this problem!!!

    I have been creating Custom Bases for a friend's servers on here and for some unknown reason the StaticObj buildings will disappear!

    Not all of the buildings of that type will disappear at the same time and will only come back once the server is restarted.

    Has anyone else been experiencing this problem? If so have you been able to fix it short of not using the new Static Objects for base building or custom areas!

  • I finally got the answer you we're waiting for.

    After trying everything, I was testing vehicle events and saw that negative coordinates on rotation don't work.

    Connected the two of them, and saw if all Objects that were desappearing had negative rotation degree.

    Yup, running more tests here, but I think that will bypass this issue.

    Solution: Rotate the object to a positive rotation (There are negative and positive rotation that will give you the same rotation)

  • Yes I am having the same Issue. I will try the trick to fix it this way. On Bhallshads discord server there is another patch posted there and I did try that but so far it hasnt worked. Im going to do some more digging in my server to make sure that nothing else caused the patch not to work, but basically you add each item type to the types file with 45 day lifetime. I did this yesterday and added all the walls and fences. Total time to write the patch was about 2 hours. I am definitely going to check the orientation of the items in my json files and see if changing those helps. Ill keep you posted

  • Car parts aren't spawning for me. I know that they were because we tested a mod that involved converting a hood into sheet metal.

    I've looked at my xml but I can't find the problem. Does anyone have any idea why this might be happening and where I should look to try and fix it?

    I've rolled back to several previous saves and the problem persists, could this be a setting issue? Im trying to avoid scrapping the entire server and starting from the ground floor if I can.

  • I thought that I should list the steps ive taken to fix the issue as well. I tried resetting my car spawns first. When that didnt help I rolled back to two previous saves. The proble was still there.

    So now Ive retyped my types xml, adding onto my clean copy as I go. Ill update my results here.

  • Well....the game loads no problem. But I'm still not getting part spawns. I can see the code for the items in my XML.

    Can I adjust the parameters to increase the spawn? I'm thinking that they might just be set to low, but I'm not sure.

    Uploading my types XML in case someone can spot what the heck I've done wrong. (I've used a validator and diffchecker)

    Thanks in advance :)


  • Thank you so much!

    Let me give you a little more detail about the issues Im having. We are using the Iztek map

    A hood appeared on a wrecked Sarka, but it was gone the next day. A buddy said that it likely just despawned. Which made me think that parts are appearing its just SUPER rare.

    I've not found a single engine part in any wreck.

    Wild car spawns don't have all of the tires.

    We aren't finding any tires on any wrecked cars.

    While wrecked Olgas and Wreaks Sarkas will have doors and on occasion a hood our wrecked Adas aren't spawning any doors, tires, or trunks at all. We havent seen a Gunter.

    We aren't finding tires on wreaks or in the industrial areas.

    :) I tried to tweak what I thought was the spawn rate, and then we started finding only Sarkas EVERYWHERE lol

    in hallways, in greenhouses, and in storefronts, Only Sarkas though I quickly restored the types back up and reached out.

    Lastly spawned cars are disappearing in a blink as soon as the player moves to far from them.

    I found this solution online, but I haven't implemented it yet. Vehicles Despawning?? : dayz

    I have added a car trader to counter the issues for the players, BUT i want better to understand how things are formated and work..

    I really appreciate you taking the time to take a look.

  • I should preface this by saying this on the Livonia map...Since the latest update, all the cars spawn in with nothing. I mean NOTHING. No tires, no doors, nothing in the trunk. Just shells of vehicles. It happens to every single vehicle. I have reset the children to 0, waited 30 mins, then reset to 1; and gone through the xml and made sure there were no errors. Everything worked fine before the update and I haven't changed anything post update. I am losing my mind with this crap.

  • Alright so I took a day and went through all the files again. Found the issue. If you are going to have stuff spawn in the trunk, they need to be listed as cargo, not attachments. I also went through and validated the file after EVERY change. Yeah it took a while, but guaranteed no issues, and now all my cars spawn complete and with stuff in the trunk. Now if I could just figure out why first aid kits and ammo boxes spawn empty....I have attached the updated file to save someone else the pain.

  • My servers been giving me some trouble by not spawning new loot or despawning older items (some items i have seen 3 days ago still exist), i have already have changed the "CleanupAvoidance" type to 0, does someone know what i am doing wrong?