Crossark is setup correctly, but whenever I switch server I lose my tribe membership.

Become part of a great team that has nothing less as its goal than to be the world's best game server provider. Keep facing new, challenging and exciting tasks at a company that values your opinion.


open positions @ Nitrado
  • Hi,

    I'm sorry if this has been addressed before and I somehow missed the post.
    I have two servers in my cluster: Valguero and The Island. Whenever I travel between the servers, I lose my tribe membership, which is odd because there are people in my tribe still on Valguero and vice versa when I travel between the maps.

    As of now, I am on The Island and I need to get back to Valguero, but am no longer in the tribe.


    What am I doing wrong and what can I do to prevent this from happening? I was the tribe leader in my tribe on Valguero, now I have lost tribe membership and along with it access to all of my dinos. I have tried everything from a simple relog, to server rollback to see if it would happen again, and it just keeps happening.

    Thanks in advance for your help. Please let me know if you need any more information from me.


    If it is of any help, I created the same tribe on both servers, same name on them.

  • Well, this is a new issue. Other current CA issues exist.


    Moving players around seems to be one of the bigger issues. CrossARK ultimately is a risk. To resolve your issue is have the admin force you in your tribe. Once you are in in, things should be back to normal. I spend way more time doing admin functions with the CA issues then anything else.


    Personally I have not had the tribe issue. Then again I have always created my tribe on all CA servers first before porting them. ;)

    Typically a server rollback would not fix the issue as the CA is in a cloud.

  • So we've been having similar issues, but slightly different, and it's been very heavily related to Valguero. We've seen it both from transferring from one server to another, to even not transferring at all and just logging out. We disable dino/item transfers between our pve maps because they are also linked to our pvp maps (dont want them being used as storage banks for our pvp players) but we separated the pve maps into their own cluster for a couple of days when we opened our valguero map to allow transfers, and we had several people get disconnected from their tribes. There were also multiple instances of players losing their characters, but thats a different post. What I had them do since there was 2 of them is alternate who went back to the rag map to get more stuff and one person stayed on the val map. We havent had any disconnects on rag, and its only been on Val, so this method worked for them. Took longer, but there was always someone online in the tribe that could invite them back if it came to it. Oddly enough once they started doing that, they had no more issues.


    The second scenario I've experienced personally. I created a character on the val pve map, and every time i logged off, i would be disconnected from the tribe when i logged back in. Being the server owner it was easy enough for me to force back into the tribe, but it was scarily consistent. Then out of the blue yesterday it stopped happening and I've been in the tribe whenever i log back in so far. There's been a couple of other instances with other players that theyve been disconnected as well, which really sucks from an admin side because they were solo, and the forcejointribe, forceplayertojointribe Specimen ID Tribename, forceplayertojointargettribe, and forceplayertojointargettribe specimen id commands do not work if there is no one in the tribe. So the only option at that point is to leave the admin tribe, start a new tribe, and either use giveallstructure or taketribe, hand over ownership, and then rejoin the admin tribe again.


    So the simple of all of that, is that I think it's a Valguero thing more than any other map. Between the actual map progress (visibility of the player map) not being retained, tribes being disconnected, and just overall character related issues, to me it seems like an issue with the map itself. Since you are transferring though, its adding the nitrado side of it as a variable as well. To rule it out, make sure nothing is uploaded, and then shut down the servers and generate a new cluster id, double check the settings are still correct, and then start it back up. Or if you are not the owner, you can suggest that to the owner. I have no idea if it will help or not, but its really the only thing you can control and rule out as a variable. After that it could be either CA having more issues, or Valguero being super glitchy still (we still have invisible ice wyverns and broodmother on console, :P ).


    Sorry for the super long post. Since we've been having these issues on our cluster i've been doing a ton of testing and troubleshooting and note taking trying to find a cause and how to fix it, if possible.

    Not knowing something Yesterday just creates opportunity for growth Today. Strive to learn and do better, and be better for it.

  • Hi Doagen and Shadowxfire,

    Thanks for the responses! :)

    I created the tribes on both maps before transferring between them, however the issue with the disappearing tribe membership still exists. It's a bit of a conondrum, really!


    I'll see if I can sort the issue out somehow. I called customer services who weren't able to help unfortantely, so if I can't get this to work then I'm not sure what else I can do.

    Maybe it is a Valguero specific issue, I just might have to try a different map and see how that works, or generate a new cluster ID and try that method out.


    Thanks again for responding to me!

  • Personally I do not think it is isolated to Valguero. I have had issues with CrossARK on about 10 different maps. CA has known issues/bugs for years. But for some odd reason it seems to be alot lately. I am aware WC and Nitrado are working on their own CA issues atm. Maybe something will become of all of this. Us existing Server Admins just do what we can to help folks. I put a disclaimer on my CA's: "At your own risk". But the dino not in tribe things is pretty easy to fix. If you are using PC servers, install ACM, yes- ACM. Once its installed and you have it activated, press I believe F3 (watch the screen to see the command) and punch. Instantly take over your dinos. Or you can use the old fashion take target command.