***Items persisting and not being removed from game - Ongoing bug with Nitrado servers***

Nitrado now has an official Discord server to bring communities, friends and other gamers together!
Join the Nitrado Community Discord now and share your experiences and knowledge with others!

Click here to go to the Discord Server!
  • Seems to be an issue with items not despawning. I will attach all I have done so far, this is just 1 item for an example, there are quite a few others:


    XML file edited for ALL torches:

    <type name="Headtorch_Black">

    <nominal>0</nominal>

    <lifetime>3</lifetime> (Lifetime at 3 seconds to make sure it despawns almost instantly upon server wipe / player join)

    <restock>0</restock>

    <min>0</min> (Should be none spawning due to this after the possible 1 spawns on server wipe)


    Globals:

    <var name="IdleModeCountdown" type="0" value="302400"/> (Server has basically a non-idle phase, so items should continue to despawn even if players are not online for half a week which wouldn't happen)

    <var name="CleanupAvoidance" type="0" value="10"/> (Reduced from 100m, so items should despawn when players are close)


    mpMissions - Storage_1: has been wiped multiple times attempting this. Server is then restarted. Items still spawn (Head torch is 1 of probably 10 others that should not be appearing, some work, some do not)


    Why do items still spawn and why are they not being removed, especially with the timers and minimum set to 0. I have never had this issue on any other server provider bar Nitrado, so it would be good to find out why so other players can have the fix as well. (I have looked at posts going back 2 years and this has still not been answered or solved) :?::!:

  • ***Update***


    Tried to add all items to the IgnoreCFG list, wiped Storage_1, rebooted server, items still spawning

    Tried to then delete the item entries from the Types.XML file, wiped Storage_1, rebooted server, items still spawning!


    There appears to be no fix for this? I am assuming from the 100+ people viewing this thread with no response, even from Nitrado themselves, there is no known fix.


    I have further investigated and messaged the DayZ Expansion modding team on Discord, they dont appear to be able to give me an answer either. However this is on the BASE GAME and not part of the expansion, so is nothing to do with that side of things. Would be great to have guidance or an answer from someone.

  • Hi to disable idlemode


    set:


    <var name="IdleModeCountdown" type="0" value="0"/>

    <var name="IdleModeStartup" type="0" value="0"/>


    Have you also checked "CleanupAvoidance" ? Its the distance from player required for item deletion.