Not Requiring Password to Log On to Server

Nitrado now has an official Discord server to bring communities, friends and other gamers together!
Join the Nitrado Community Discord now and share your experiences and knowledge with others!

Click here to go to the Discord Server!
  • I set up my ATLAS server and can access it from the server list. However, I set up a server password when creating the server. But it does not require one when selecting the server from the server list & Steam does not show it as password protected in the Favorites. Anyone know I can fix this?

  • Just to clarify, DOAGEN ...

    On the Dashboard page underneath the "Restart ATLAS" button, I see


    Atlas Settings

    Mapname:

    Blackwood

    Servername:

    ********

    Server Password:

    ********

    1x1 Map selected

    Currently a 1x1 map is selected. This map does not support grid functions. Grid options disabled.

    Save Button


    I'm assuming we should enter the password into the Server Password box in this section. Seems a safe assumption in any case. When I set it up, The server is active and shows the correct name, but does not require any password at all. I think the issue is that the ATLAS password is stored in the servergrid.json file for a normal ATLAS map created through the server grid editor, while Blackwood maps seem to require a command line argument for the password, i.e. "start ShooterGameServer.exe Blackwood?ServerPassword=XXX?ServerAdminPassword=XXX?MaxPlayers=20?ReservedPlayerSlots=0?QueryPort=*****?Port=*****? -log -server -NoSeamlessServer". Unfortunately, we can't access the command line directly. Putting the password into GameUserSettings.ini (like you would for ARK) doesn't work either. Hopefully they'll get this resolved soon.


    Is there a way to enable the -exclusivejoin option? I can't find the setting anywhere on the Nitrado web interface, but I know it can be done in ATLAS.