Unable to get admin on my server

Dear forum members,
for some time now we have been creating and maintaining new ways to help game server admins with questions and problems as quickly as possible, e.g. our Guides section and the Nitrado Community Discord.

Therefore, we inform you that the Nitrado Forum will be closed on March 31, 2023. We are consolidating our community support to our Discord channel, which is faster and more efficient. We have also seen incredible growth in our community due to the hard work of our moderators and our bots. We are confident that this move will ensure that we provide the best support possible for our users.

Thank you to all members for your continued use of the forum!

Assistance with all questions concerning your Nitrado service can now be found in these spots:
Community Discord: https://discord.gg/nitrado
Guides section: https://server.nitrado.net/guides
Support Wizard: https://support.nitrado.net
  • I have sent a ticket in, and it was remarkably unhelpful. I told them I had tried the instructions on the wiki, and they don't work. They directed me BACK to the page that the instructions don't work.


    When I open the start menu, and open options, and hit tab nothing happens. There is no place to input my password and request admin.

    In other games I have had on my Nitrado server, there was always a place inside the Nitrado dashboard to put in my steam ID as admin. I was surprised that doesn't exist for this game.

    Have any of the other admins figured this out? Surprisingly (not) Nitrado is no help. Thanks!

  • Not sure what to tell you, everything Nitrado Support provided is how I have always done PixARK. And I just popped up a server and it worked fine to be an admin.

    You wont be able to add it to the Dashboard as it does not exist. If the Devs open up that access, and it goes through the Nitrado Dev team it may or may not be added at some point.

    Sorry you are having issues. I'd contact support back.

  • I have contacted support, they just keep pointing me back to the page that doesn't work for me.

    Maybe I am misunderstanding the instructions. When I am in my game, i hit escape to bring me to the menu that has "options" when I click into options, and hit tab, nothing happens. I have tried just hitting tab when the start menu pops up. There is nothing I can see that allows me to put in password or request admin. When i go into the game and hit tab to open up the console commands, nothing happens if i type there.

    It does seem like I have a new password every time I look at the dashboard. I didn't set anything, it's just the random letters/numbers generated by the game. But they are different every time I look at it.

    Thank you