High Ping on Blackwood Map

Dear forum members,
for some time now we have been creating and maintaining new ways to help game server admins with questions and problems as quickly as possible, e.g. our Guides section and the Nitrado Community Discord.

Therefore, we inform you that the Nitrado Forum will be closed on March 31, 2023. We are consolidating our community support to our Discord channel, which is faster and more efficient. We have also seen incredible growth in our community due to the hard work of our moderators and our bots. We are confident that this move will ensure that we provide the best support possible for our users.

Thank you to all members for your continued use of the forum!

Assistance with all questions concerning your Nitrado service can now be found in these spots:
Community Discord: https://discord.gg/nitrado
Guides section: https://server.nitrado.net/guides
Support Wizard: https://support.nitrado.net
  • While playing today a had a high ping jump with alot of lag on my Atlas Blackwood map server. I don't have the same lag and high pings on my cluster server. Is anyone else experiencing this or have any ideas on how to remedy it?


  • I tried logging into on another xbox with a different profile and didn't have the lag. I also tried logging into a different profile on the same xbox that had the lag and didn't have any lag or high pings either. I even tried to clear my local cache and had the same issues of lag and high ping with the first profile as well. Really weird issue I'm facing here.

  • Hello, I need advice. I have a high ping on my server. When I log in to the game, I get a high ping 255 and after a while the server crashes and restarts. due to the high ping you can't stimulate anything otherwise I wasted money unnecessarily. Thank you, Zergos

  • If you haven't already, submit a support ticket so they can look at things from their side. I've had some similar issues in the past and they migrated my service to a different set of hardware or were able to make changes on their end that fixed the problem.

    ATLAS can be a finicky bugger sometimes. Hope you get it resolved!