Cannot join server game loads to 99% and then connection lost

Nitrado now has an official Discord server to bring communities, friends and other gamers together!
Join the Nitrado Community Discord now and share your experiences and knowledge with others!

Click here to go to the Discord Server!
  • Does anyone know why I cannot join my own server goes to 99% and then the connection is lost all my friends can join but i cannot join


    I have tried the following.


    Restarting the server.

    Trying a blank save game

    Downloaded the save game and host it from my pc and it works fine.

    Verify game files on steam


    Mods up to date( Universal Autoload, Guidance steering, Light range increase, Paint anywhere)


    Does anyone have any suggestions?

  • Additional Stepps Tried Rebooted my router disabled the AV Reinstalled the game server. we are 2 people on the same network my friend can join the server but I cannot.


    I have also tried a brand new save on the server but still nothing.


    As mentioned I have downloaded the save game and manually hosted the server from my pc and it works fine no issues everyone can connect.


    Also I can connect to any other FS22 multiplayer server without an issue.


    This must be something on the server side but as usual it takes forever to get support or response from nitrado.

  • Hello,

    This is a Community support Forum for gamers and admins like yourself to help and ask questions of each other.

    We do not have access to your servers or accounts here.

    Based on everything you had already posted, please reach out to Nitrado Support (appears you have already).

    It is the weekend. Please allow 24-48hrs for a response.

    Thank you.

  • Got the same problem ... :/


    How did you resolved it please ?

    Either it self resolved or they contacted support.


    /closing thread. This is an old thread that was already marked as closed/resolved.

  • DOAGEN

    Closed the thread.