Here is how to add mods to the server.

Nitrado now has an official Discord server to bring communities, friends and other gamers together!
Join the Nitrado Community Discord now and share your experiences and knowledge with others!

Click here to go to the Discord Server!
    1. Add the mod id from the steam workshop to the configuration file with each number getting it's own line. Just like the video that can be found on YouTube but not directly listed anywhere on these forums, the website or the wikis says to do.
    2. Upload each mod to usmi200.gamedata.io/spaceeng/Content/Mods/ and to usmi200.gamedata.io/spaceeng_profile/Mods
    3. Stop server if it was running. If done correctly and the mods do not cause a crash the server should start right up.

    I'm guessing there is an automatic action that is supposed to happen after step 1 that never gets completed. I spent a good 30-40 minutes looking all over the website, forums and wiki for information on this. Honestly there is a gap in important info like this for all the game servers. Step it up Nitrado.

  • Log into you WebUI and your FTP info is there. You would use apps like Filezilla to upload the files.

    i've done all that now, after finally figuring that out. However now i've loaded my server up again, when i login to my world i still dont see any of the mods active?


    what does it take to get mods working here?

  • Update but not working: I've ordered one server today and also set it up with many mods. Some got loaded and also worked ingame...BUT asteroids were not generated in any form also after switching the settings and also no resources were added on the server (I think this happend thx to the better stone mod). My logs say, that the server loaded all mods sucesfully from steam. Not a single downloadproblem or anything.


    The real problem what I could find in the logs were that the server couldn't load the mods into the savegame. I also tried to set up an vanilla world and add the mods after the vanilla world was created. Dind#nt work. Haven't tested if it work when you create the game in your client with all mods and the nupload this safegame on your SE-Server via FTP.


    The Nitrado-Support-Team is working on it.

  • Just purchased a server. Added the steam ID's of the mods I wanted and also uploaded them into the sections mentioned in the OP. I still don't have any mod loading at all. Is there a more detailed explanation of how to do this? Was I correct in simply transferring the files directly over as they appeared in my PC? Do I need to exclude or include any files that steam normally associates with its mods? Does its visibility on steam cause interference with mod loading? Thanks for any help.

  • Just purchased a server. Added the steam ID's of the mods I wanted and also uploaded them into the sections mentioned in the OP. I still don't have any mod loading at all. Is there a more detailed explanation of how to do this? Was I correct in simply transferring the files directly over as they appeared in my PC? Do I need to exclude or include any files that steam normally associates with its mods? Does its visibility on steam cause interference with mod loading? Thanks for any help.

    Disregard this post. No clue what happened, but after manually entering 2 mods and seeing if visibility was an issue. I restarted the server and suddenly all the mods loaded. No idea what happened, but not complaining either.

  • I didn't do anything except put the ID's in the general page and it was working fine for 3 days, didn't even know about copying them to folders. Now it's not working and it's getting frustrating, I've been with Nitrado for over a year but this is stupid, I'm switching to GTX for this game