Can't select Avorion as a new game server

Nitrado now has an official Discord server to bring communities, friends and other gamers together!
Join the Nitrado Community Discord now and share your experiences and knowledge with others!

Click here to go to the Discord Server!
  • I wanted to change my current game server over to Avorion. I saw on the 'store' page that you can rent one for this game. However, when I try to change to Avorion it doesn't show up as a game title. What am I missing?

  • It is because that game has a different server hardware requirements. So 'change' game is not available. However if you go into as if you were purchasing a new server, select the game it will let you proceed. You may also contact Nitrado Support and they may be able to make this easier for you.

  • Ok thanks for the quick answer.

    I originally tried to do that first. I just tried it again. I navigate to the Products -> Gameserver page to select 'Avorion'. From there I get the typical choices of levels of server you want to purchase. Regardless of which level I choose, the page simply goes back to the original landing page for gameservers.

    Since I couldn't get it to go from there, I picked a Minecraft server, paid for the level I'd generally want, and once it was built, figured I'd switch to Avorion - which takes me back to my first topic - I can't select Avorion as a game type to switch to.

    I'm stuck is some loop.

  • Then please reach out to Nitrado Support.

    Support info is in my signature and at the bottom of this site.

    Moderators have no access to accounts or servers.

    *I was able to select that game as a new customer, and as an existing one to purchase new one. I was not able to change an existing server to this game.