Mods on Expansion servers not loading

  • Hey there,


    I recently moved a working 3X3 grid to Nitrado. After struggling with their .json method of overwriting game.ini and gameusersettings.ini I got the mainserver to work correctly. Now none of the expansion servers would use the settings from game.ini & gameusersettings.ini and they do not load any mods.


    After uploading the game.ini & gameusersettings.ini to each expansion server seperatly and uploading all of the mods to each server seperatly, some of my settings worked, but the expansion servers still do not load any mods at all, despite the uploaded gameusersettings.ini containing the correct "Activemods=" settings.


    So I'm caught bewteen a rock and a hard place since:


    1. All of the expansion servers seem to ignore the game.ini and gameusersettings.ini from the main server. (Yes, the option "Ignore Main Server Settings" is NOT tagged on any of the expansion servers)


    2. All of the expansion servers ignore the "Activemods=" settings from their individual gameusersettings.ini. (Which the expansion servers apparently process, despite they're set to use main server settings. Although it seems they only process the settings you can adjust using Nitrado's interface, which of course doesn't include modid numbers).


    Like I said the cluster worked until Sunday on 2 dedicated servers for a few month without problems and since the main server still works as intended after the move to Nitrado, I am pretty sure the configuration is correct.


    I'm at a loss here, any ideas?

  • Not sure why you are having a problem of the main server, and the expansions. you dont have to touch the json at all if you want to use the default map. and the web interface is used for server settings. As for the mods, just put the mod id on the web interface on each server once they are connected, save, restart.

  • Ok, maybe I was not being as clear on this as I thought:


    "you dont have to touch the json at all if you want to use the default map"

    I thought this was clear with me saying that I moved a complete 3X3 server cluster from another provider to this place here. But let me emphasize this : Nothing is "default", not the map (made it myself) not the quests, not the regional settings nor (almost) any game.ini and gus.ini settings. And yes it ran fine for several month before moving here. All these changes were carefully made over these month to get a balanced gameplay for a low population server. Nothing rushed, nothing half baked.


    "and the web interface is used for server settings"

    No, just, you know....no. The webinterface not even covers half of the settings needed and less then 1/3 of the settings possible for Atlas.


    "As for the mods, just put the mod id on the web interface on each server once they are connected, save, restart."


    Again...No. There's no option to fill in mod ids on the expansion servers, plus the expansion servers do NOT use the game.ini and gus.ini settings from main as described in the Nitradopedia, quoting here:

    "Every Atlas (which is one shared game world) needs exactly one main server. The game name of this Nitrado server will be “Atlas” or “Atlas (Main Server)”. This is the server where you can adjust the settings of the entire grid in one place, instead of accessing every server in the grid manually."


    Doing exactly as desribed above the expansion servers were completly ignoring the main server's settings. I had to upload game.ini and gameusersettings.ini to each and every cluster (expansion)server seperatly, and only after this step was taken the settings available from the webinterface were being considered by the servers at launch, only those, not all of the settings and still no mods at all were loaded.


    "Not sure why you are having a problem of the main server"

    Sorry if I do seem to repeat myself, but my problem is not with the main server (which is also my homeserver), that one runs perfectly just as expected. It's the impossibility to make the expansion servers behave the same way (reading the same game.ini and gus.ini settings as the main and loading the same mods as the main). And needless to say the mods are registered into the original map's servergrid.json as well, not only within the gus.ini with the "Activemods=" setting.


    Puh, this has become a wall of text now, I do apologize..


    I'm not blaming anyone here on the forums for I know you want to help, but I get the feeling Nitrado should allow users to freely update and manage the expansion servers if they wish to, all those forced use of a less then complete webinterface makes it unmanagable.

  • Well, I have managed and ran my own atlas 4x4 cluster and know of all you are stating. And I had much custom myself. It would be nice if you could just grab a json from another host and move it, but you can't due to the custom things folks do, and even the hosts. And you can run separate ini files still when clustered (knowing you do not, and better to run off the one). I know of a huge cluster doing this and works as you state above. Sadly they are no longer hosting atlas, nor am I. I have done cluster, with and without shared ini files being used, and modIDs.


    Maybe someone in the Community can assist with what you need assistance with.


    Or you may contact Nitrado Support if you feel the servers are having issues ie not connecting.

    They can be reached with a phone call or by ticket.

    Support | nitrado.net

  • First of all, I have to point out that the only relevant .json file is the servergrid.json and it is made with the same program for every server cluster out there, even the official one. So, sadly, no, the servergrid.json is the same, whatever your provider is (except for the Game ID, IP's, Ports, which of course need to be configured for the machines the gameservers are using)


    Today customer service mumbled something about my savegames being corrupted, they changed all my IP's and ports and said it should be ok now. And they said that, indeed, there's no possibility to define mods for the expansion servers, as they are transferred from the main server.


    Sooo.......


    Nothing, I'm afraid, the problem persists:


    Main Server reads game.ini and gus.ini, behaving normal and loads all the mods.


    Every expansion server ignores all of this and consequently runs with standard features and no mods at all.


    Asked for a refund today.


    The sad truth is: It's their own attempt at imposing an interface who is interferring with server setup (overwriting game.ini and gus.ini & creating a third party .json for loading the mods) that creates those problems. If the experienced user would have the option to setup the servers as intended by Grapeshot Games, my cluster would have been up and running a week ago.


    Bye and thank you Doagen for at least trying to help....