Nonstop Server Restarts, and Inability to Connect

Dear forum members,
for some time now we have been creating and maintaining new ways to help game server admins with questions and problems as quickly as possible, e.g. our Guides section and the Nitrado Community Discord.

Therefore, we inform you that the Nitrado Forum will be closed on March 31, 2023. We are consolidating our community support to our Discord channel, which is faster and more efficient. We have also seen incredible growth in our community due to the hard work of our moderators and our bots. We are confident that this move will ensure that we provide the best support possible for our users.

Thank you to all members for your continued use of the forum!

Assistance with all questions concerning your Nitrado service can now be found in these spots:
Community Discord:
Guides section:
Support Wizard:
  • Background:

    Purchased a 10 slot 7Dtd server this morning, around 0800 PST. Have owned Nitrado servers before, for Ark. I've been playing 7DtD with several family members for the last several weeks. I wanted to upload our existing map, characters, data, etc to the server and continue playing where we left off. I've spent all day going through various forums, wikis, how-to's etc. With little success or help. I found a couple forums that somewhat walked me through it. I utilized Filezilla and connected to the server's IP and directly uploaded both the "GeneratedWorlds" & "Saves" folders, in their entirety, to the server (they were too large, even zipped, to import them through nitrado's download interface). It was successful, and I could see the files and map and everything in the various Nitrado settings.

    I then went to the config settings and changed the following four areas:

    "GameWorld" ---> changed the value from "Navezgane" to "Voluya Territory"

    "WorldGenSeed" ---> changed value from "asdf" to "Woodbury"

    "WorldGenSize" ---> changed value from "4096" to "8192"

    "GameName" ---> changed value from "MyGame" to "Woodbury"

    All these values were the values of my map that my family has been playing on. After doing this, saving the settings the server restarted. From this point onwards, it just restarts, says its online for maybe 1-4minutes, but when trying to connect to it through the nitrado interface, the steam window that pops up says it cannot contact the server. When trying to find it in the game interface in the join a game area, it's nowhere to be found. And it just keeps restarting over and over.

    I called support around 1200 PST today. They said they would move it to a "different machine". She advised it would take 30minutes. I waited. Still doing the same thing. Nonstop restarts, inability to connect, even when putting in the servers direct IP and Port.

    I called support again at around 1641, they said the only thing they could do is reinstall the server, to remove the files I uploaded as those were probably causing the crashes/restarts and inability to connect...I already figured this, was more looking for help on what I need to do to get the map I want as my server. She stated I would need to look to wikis and there is a "lot of good information" on there. I don't discredit this, but for this particular issue, I am not finding anything that works. So, that is why I am now posting here.

    The server just technically, I can probably play on it. However, all the files I uploaded via filezilla are gone. I have no desire to play a fresh map. No desire to start over. Neither does any of my family. I would sincerely and truly appreciate any help, insight or step by step process to be able to get my map as the server map with all our data (characters, items, bases, etc). For now, I will refrain from repeateing the steps I did earlier, as they didn't work, and I don't want to put the server back into a continuous restarting loop.

    Thank you for your time in this matter.

  • So, it appears, my files I uploaded through FTP via Filezilla are still present. The reinstall of the server by the Nitrado employee simply just reset the config.xml...So, here's a few pictures showing the files I've gotten onto the server database. The Navezgane (default) map/file is back. I've noticed and think that if I can get my Voluya Territory folder to where this Navezgane folder is, and replace it (and then do all the config stuff) that it might work...but how do I do that?

    -The first picture is showing the file center for my server, the "7DaystoDie" folder is there by default, I added the other two folders (all the data for my map).

    -Second picture is showing that default path, to what is the current map/game (I have loaded up the server or done anything. This is just the default world/map/setting

    -The third-fifth pictures is just me showing the path/folders of my map and that all the data is there

  • Ok, so I've answered my secondary question/reply. I deleted the files I uploaded via filezilla and redownloaded them. This time, using filezilla I actually replaced the "saves" file in the Nitrado directory, with mine, and deleted the Navezgane folder. I then put the "generatedworlds" folder, in this new "saves" folder. Everything made it over. I then changed the same 4 config.xml areas again and restarted the server....aaaaaaannnnnnd I'm back to an endless loop of restarting and when I try to connect to it, steam says "server is not responding" and then makes the server restart I'm out of ideas...Anyone...please help?

    Pictures show the new layout of my files/directories within the Nitrado Server File area

  • It's been nearly 24 hours now. Same issue, haven't even been able to play on the newly bought server. There is no help or guidance on their youtube channel, these forums, or from anyone. This is pretty frustrating and honestly ridiculous. I can't be the only one that has ever tried or wanted to upload an existing world to a server...

  • After roughly 12 hours of youtube videos, forum browsing, google searches and trial & error...I've finally successfully uploaded my multiplayer map, with all of my character data and my family's (5 other individuals) character data. All of our levels are present, every item we've looted and stored and everything we've built. The map and all the POIs are present, etc etc. It's as if I just went straight into steam and launched my save game...except it's finally on my server.

    There is NO CLEAR guide on how to do this, that I have found, unless your fortunate enough that your files are small enough to be uploaded straight into nitrado (after zipping them). Which is unlikely, because mine (zipped) were only 120-160mb. So, if you want to upload an existing map of yours (mine was multiplayer) and it is too large. I will outline below what finally worked for me.

    -First off you are going to need to download Filezilla: FileZilla - The free FTP solution

    -You will also need to locate your saved data for your map(s). For me, mine was under C drive-->Users-->Admin-->AppData*-->Roaming-->7DaysToDie**

    -It is possible for the data to be in other locations. Such as, instead of Roaming, under "LocalLow" or under C drive-->Program Files (x86)-->Steam-->steamapps->common->7DaysToDie

    *=In order to see AppData you must have "Hidden Items" checked. If you're on Windows 10, click on the view tab at the top and check the box

    **=Once here, you will see a "Saves" and a "GeneratedWorlds" folder. These are the two folders you will need.

    -Next up you will need to launch Filezilla. After doing so you will need to connect to your server by inputting the required 4 fields at the top of Filezilla: "Host" "Username" "Password" and "Port". You can find all this information on the "Dashboard" of your server, near the bottom.

    -Once you've successfully connected your server, you can see 4 various windows. The left-hand side is the "Local site" (Your computer) and the righthand side is the "Remote site" (Your server). You will want to navigate to the files we found earlier, on the left hand side. (See Pictures 8-9 for examples)

    -Once you've found the files in the Local Site you will need to drag and drop them to the appropriate locations on the "remote side". This is EXTREMELY IMPORTANT. If you do not place them in the right areas, your server will not work. It will continually restart and you will not be able to connect to it.

    -Lets start with the "Saves" folder. You will need to click on the "7daystodie" folder on the REMOTE site. This will open up all of its contents in the lower righthand window. You will then click on the "Saves" folder on the LOCAL site and drag it over to that lower righthand window and drop it anywhere BELOW the other folders presents (don't drop it into a folder). This will start the transfer process and can take several minutes. Mine took probably 15 mins. Should anything pop up saying something already exists, simply check the overwrite box always for this queue option.

    -Once the transfer process completes for the "Saves" folder. You can now migrate over the "GeneratedWorlds" folder.

    -In the lower righthand corner window, you will see various folders including the new "saves" folder. Double click on the "Data" folder. Then double click the "Worlds" folder. This is the location where we will be dropping our existing map and all its data.

    -Now in the lower left-hand corner (LOCAL site) you will need to double click the "GeneratedWorlds" folder that you found. Once it opens, you should see the name of the World that you had saved. For me, it was 'Voluya Territory". You are going to drag and drop this folder over to the REMOTE site's lower righthand corner, anywhere under the other folders (don't drop it into any of the folders). This will initiate your second and final transfer process. It'll take several minutes, mine took around 10 minutes.

    -Once BOTH transfers are complete, you can close Filezilla. Go back to your server page, and click on "Config Files"

    -Then click on "serverconfig.xml" if you're not already on it. (It'll be the second option, if you click on the black box that says "serveradmin.xml"

    -Now we will need to change 4 settings in here. (See picture 10) "GameWorld" "WorldGenSeed" "WorldGenSize" and "GameName". These settings can be found in your game interface, when you go to load up or create a new game, you can see your previous game. The game world setting is the world your map is in. Mine was "Voluya Territory". The WorldGenSeed is the seed of your map. I didn't use a seed for mine, so my seed is whatever I NAMED my map. In this case, "Woodbury". WorldGenSize is the size of your world. Mine was a 8192x8192. Lastly, the actual name of your game/map (what YOU named it), mine was "Woodbury".

    -You are going to change the "value" of each of these lines of data. So stay within the quotations " " and only alter anything within them, with your appropriate data.

    -After you've done this. Click save changes at the bottom. Then restart your server. After it restarts, it may take a few minutes to connect, even if it says the server is started. Took me probably 2-3mins before I could actually connect. If you followed these instructions, and your Nitrado 7DaystoDie files look like mine (names varying) (see pictures 1-7) then this SHOULD work for you.

    I've tried to make this as clear and concise as I can. I sincerely hope this helps, because I've poured through numerous threads with people trying to do this same thing, and not getting any answers and being left in the dark. This is what worked for me. It took hours of playing with the file locations to figure it out. Looking at guides from like PingPerfect or How to upload a singleplayer world to your 7 Days to Die Server | 7 Days to Die | Knowledgebase Article - Nodecraft helped, and pointed me in the right direction. But they aren't the Nitrado interface. And Nitrado has different names for their files (eg. Worlds instead of generated worlds). If you have questions, feel free to message me, I will do my best to help. I'm by no means an expert in any of this stuff...just someone who devoted the better part of the last 24 hours to figuring it out, because there was no good information out there.

  • Thank you very much for this walk through, sorry it was at your inconvenience but i am also three days in trying to get this all to work. The downside is im trying to download darknesss falls mod into the server and well....its not going so well haha.