Can't connect to the server after the update

Nitrado now has an official Discord server to bring communities, friends and other gamers together!
Join the Nitrado Community Discord now and share your experiences and knowledge with others!

Click here to go to the Discord Server!
  • I submitted my ticket at 2pm today, and I am still waiting.
    Last year, I submitted a ticket, it took them 2 days to reply without any solution on my Ark Server.

    Update: Got a trash respond from Nitrado. "Restart Server and try to connect through the game."

    OR

    "If you are having issues connecting your server since the last update, please restart the server and try again. Alternatively, you can use a 2nd connection method explained in our wiki:"


    Which I am sure most of us on this Forum has already tried.

    Yup, Got the same response. I even stated in my original ticket I had already tried these.

  • I got a response from support saying "You will want to use the in-game connection with IP option after this recent patch. Steam being unable to query the server software is not something we will able to solve ourselves as we are not the game developers."


    I accept something changed with this patch but I have another server with 4netplayers and that works fine through steam with this new patch, so I don't believe it's totally down to the patch but also some server configuration is required. For my other server I do exactly the same thing in steam, that is add the ip address and port in the format <ip address>:<port number> but the port number is +1 e.g. on the server admin page the port is 2456 so I put 2457 in steam. This works fine.


    It's not clear to me why Nitrado servers don't work through steam. I can connect in game by connecting to the ip address and port shown on the server dashboard.

  • I got a response from support saying "You will want to use the in-game connection with IP option after this recent patch. Steam being unable to query the server software is not something we will able to solve ourselves as we are not the game developers."


    I accept something changed with this patch but I have another server with 4netplayers and that works fine through steam with this new patch, so I don't believe it's totally down to the patch but also some server configuration is required. For my other server I do exactly the same thing in steam, that is add the ip address and port in the format <ip address>:<port number> but the port number is +1 e.g. on the server admin page the port is 2456 so I put 2457 in steam. This works fine.


    It's not clear to me why Nitrado servers don't work through steam. I can connect in game by connecting to the ip address and port shown on the server dashboard.

    That didn't work for me and my friends either.

  • Another alternative way of connecting you can try is in Steam under your library, right click on Valheim and select properties. Under General you should launch option, enter the following depending on what your server ip address and port number is.


    +connect <ip address>:<port number>


    You should not need to +1 the port number

  • I also got the following to work.


    1. Create a new shortcut on your desktop

    2. Enter the Location of the shortcut to something like this:


    D:\Steam\steam.exe -applaunch 892970 +connect <ip address>:<port number>


    The above is an example, so change it to where your steam.exe is installed. The ip address and port number should be exactly as its shown on the Dashboard

  • Am I the only one seeming to have an issue related to not getting a legitimate Port number? 134.255.240.210:0 is the IP of my newly listed Valheim server and no matter what I do or where I look I cannot seem to figure out why I am not getting a Port. Any information is greatly appreciated. Set aside time today to really put a dent into my new world and been doing nothing but trying to connect.

  • Am I the only one seeming to have an issue related to not getting a legitimate Port number? 134.255.240.210:0 is the IP of my newly listed Valheim server and no matter what I do or where I look I cannot seem to figure out why I am not getting a Port. Any information is greatly appreciated. Set aside time today to really put a dent into my new world and been doing nothing but trying to connect.

    That sounds like an issue support needs to take care of.

  • Am I the only one still having this issue? Ever since the game update yesterday morning, I have been unable to access the server. It just keeps booting me to the main menu saying "Disconnected", without even getting to the password prompt. I put in a support ticket yesterday afternoon, and all I got in response was "try restarting the server". As if that wasn't the first thing I tried. I tried both options on the Wiki (entering the IP through Steam with the +1 at the end, and through the in game option with the normal IP). I was able to play the game just fine until yesterday morning.

  • I got a canned response to my ticket. They told me to do exactly what I told them I'd already done and it didn't work. I get that Valheim is early access and there will be bugs but there is clearly something wrong here. At least make it sound like you're looking into the problem and to hang tight for a solution.

  • Ok so I found a work around that might help some of you. I started a new game and created a new character, then I logged into my server. For some reason that allowed me in without the disconnect message. I ran around for a bit and then logged out. Went back to the main menu and logged in with my old character and all is well. Try that to see if you can get it.

  • The response i got from my ticket is to suggest moving my server to a different machine at the same location and given a new IP address number. That solved my problem. So try requesting that as a fix if all else fails.

  • The response i got from my ticket is to suggest moving my server to a different machine at the same location and given a new IP address number. That solved my problem. So try requesting that as a fix if all else fails.

    Thats the only solution for most people. I will suggest they start there, when the next patch happens