SOLVED : Find your server

Nitrado now has an official Discord server to bring communities, friends and other gamers together!
Join the Nitrado Community Discord now and share your experiences and knowledge with others!

Click here to go to the Discord Server!
  • I was having problems finding my server. The problem seems to come from the game and not Nitrado. I give my tip that can be useful to others.


    1. Start your game in Steam

    2. Back to windows and go in steam in tab view --> Servers --> add custom server (with IP of your Nitrado server and use your Nitrado Query Port for the port!!!)

    For this step, check my pictures here if it not clear for you : https://imgur.com/a/fqgufhb

    3. Then put your password and click on connect (in Steam browser)

    4. Then go back in the game, select as usual you the character selection then the game will launch your server and ask you to put your password.

    5. Play <3

  • Pinning this thread temporary.

    No support via PM.

    Important: Mods here in the forum do not have access to your services. If we advise you to contact the support, you have to create a ticket or call them. There is nothing we can do.

  • I was having problems finding my server. The problem seems to come from the game and not Nitrado. I give my tip that can be useful to others.

    The problem you describe is not solved with your workaround; it's "bypassed". The server doesn't show in the server list; it should appear there - that you can login on the server through direct connect is something else and while it lets you play on the server; your server is still not "published" as it should be -> invisible to everyone who doesn't have the IP

  • Even if the server is visible, you still could not connect without the password.

    (I assume the server list is just too big / takes too long to load. just look at ARK, the are also having the problem with the server list and the game was released quite some time ago.)

    No support via PM.

    Important: Mods here in the forum do not have access to your services. If we advise you to contact the support, you have to create a ticket or call them. There is nothing we can do.

  • I've followed all the steps, and for some reason when it starts to connect in game I just get "Disconnected" It doesn't prompt me to put in the PW again.

    Mine keeps doing the same thing. I get the Disconnected and I never get prompted for the second password. Nor do I see any of the loading screen EVER, just black.

  • DOAGEN

    Closed the thread.
  • What happens when you find your server but it has no game assigned to it? Am I doing something wrong?


    It's normal. I'm not seeing the game name either. It still works.

    No support via PM.

    Important: Mods here in the forum do not have access to your services. If we advise you to contact the support, you have to create a ticket or call them. There is nothing we can do.