Xbox server not showing in game

Dear forum members,
for some time now we have been creating and maintaining new ways to help game server admins with questions and problems as quickly as possible, e.g. our Guides section and the Nitrado Community Discord.

Therefore, we inform you that the Nitrado Forum will be closed on March 31, 2023. We are consolidating our community support to our Discord channel, which is faster and more efficient. We have also seen incredible growth in our community due to the hard work of our moderators and our bots. We are confident that this move will ensure that we provide the best support possible for our users.

Thank you to all members for your continued use of the forum!

Assistance with all questions concerning your Nitrado service can now be found in these spots:
Community Discord:
Guides section:
Support Wizard:
  • So I installed a SE Xbox server and it worked fine though changes made to it would not reflect in game so I reinstalled it. Since then, it's a no show.

    Restarted, re-installed, checked and unchecked the experimental... Tried pretty much everything that could interfere but still a no show. Wrote a ticket over 24 hours ago and still no replies. Anyone else having this issue?

    Are there people still working at Nitrado? Are they going to credit the month? :/

  • Me too. Just started a server and it says on the webpage that it is ready. However, it is not appearing at the server select page. I even went thru the filters to see if anything in there would block it and the filter options looked good.