Server keeping loop in restarting

Become part of a great team that has nothing less as its goal than to be the world's best game server provider. Keep facing new, challenging and exciting tasks at a company that values your opinion.


open positions @ Nitrado
  • Same thing is happening to a lot of Xbox Space Engineers servers...and seems to be a big issues from what I can see on this site as a whole, and I've only been here for about a day.

    If I get a reply on my support ticket that actually helps me I'll be happy, but from what I can tell their support seems to be very bad. I'm already regretting my purchase and wish I had done some more research on Nitrado first. :rolleyes:

  • If you are still having issues, some basic things to do and posted all over here.

    (1) Restart the server. If is hangs, about 5-10m a button appears to forcestop, then restart.

    (2) Check your mods and make sure they are up to date. If the server was running fine before, and now it does not while running mods its more than likely the mods.

    (3) Recently some posts started to appear about S+ causing some issues. Check out their workshop on steam for further info.

    (4) Check out the server logs. If you see crashstack, that more likely is a corrupted gamefile. It happens with ARK. Sadly the resolution is to rollback to the last known saved file. And no way knowing which one is bad. Some folks that do not feel comfortable trying this- you can contact Support. They more than likely will suggest the same. OR have they might find something else.

    (5) If all the above fails, please contact Nitrado Support to further investigate. Moderators have no access to servers or accounts. We are volunteers and able to share experiences just like the rest as this is a Community Support Forum for Gamers and Admins just like you and I.


    Link: NITRADO


    Thank you.

    Nitrado thanks you for your business.