Dayz - New Map - Namalsk

Become part of a great team that has nothing less as its goal than to be the world's best game server provider. Keep facing new, challenging and exciting tasks at a company that values your opinion.


open positions @ Nitrado
  • Hello everyone.


    I tried to install the new mod that is out "Namalsk" on my server. In the mod there is a custom dayz.cfg file, that is in the root. In this file there are some settings, and also in the file, there is a parameter who call the "Namalsk" map.

    But when I restart my server, the server somehow "overwrite" this line, and makes it "dayzoffline.chernarus". How many times i try to replace, and save, the server overwrites this file.


    In the settings, when I log into the server, I can choose Chernarus or Livonia as a DLC, but not Namalsk.


    Does anyone have any clue, what I am doing wrong? Thanks in advance! :)

  • Jaeger sir,

    This was very helpful. It worked by "ticking the box" at EXPERT MODE. Then the server does not automaticlly overwrite the dayz config file. Of corse I had to manully program the config file, but that is not super much work. I have never had to use EXPERT MODE before, so therefor I did not know this.


    You helped me good, and quick.

    Thank you sir! :)

    //Björn

  • Yes. Since I made a horrible misstake before, I wiped my server, totally clean. Then I downloaded the 2 Namalsk mods. Copied the mods to the root of the server, (i use FileZilla - file transfer program). Copied the key to key-folder. Copied the "regular.namalsk" to the MPMISSION folder. (There is regular.namalsk and hardcore.namalsk, but I stick to the easy one :) )

    Then I did as Jaeger told me to do. I marked the box in General settings "EXPERT MODE", then after that I copied the Dayz.cfg from the mod to the root and replaced the original.

    Then I restarted server, and then I stopped the server, then I programmed the .cfg so I get SERVER NAME - TIME - DATE - NUMBER OF PLAYERS ect.

    Then I saved, and started the server. Then I installed some other mods, then restarted server, and noe it works....


    :)

  • Yeah, the loop often happends if you have wrong settings in your critical server files. Like the "serverDZ.cfg". That file is very sensative. It must have a logic start, and end, otherwise you can have the loop-problem. There are a coupple of other files that are important, for stuff to work. ALWAYS LOOK AND LEARN from original files (and save a copy, so you can fix the loop).


    When you learn and see how the structures in a file looks lke and works, then you can most of the time see if there is any info missing or you accidental removed a " } " or something.


    It takes some time and some coffee and a few tears, but evntually you get the hang of it :) Here is an example of my "serverDZ.cfg" file:


    // standard server params

    hostname = "Dayz EUROPA NAMALSK Vanilla Server (Public)";

    password = "";

    passwordAdmin = "xxx-xxx-xxx";

    maxPlayers = 32;

    verifySignatures = 2;

    forceSameBuild = 1;

    disableVoN = 0;

    vonCodecQuality = 20;

    disable3rdPerson = 1;

    disableCrosshair = 0;

    guaranteedUpdates = 1;

    loginQueueConcurrentPlayers = 5;

    loginQueueMaxPlayers = 500;

    instanceId = 1;

    storageAutoFix = 1;


    // custom Namalsk edits

    serverTime = "2011/7/7/9/01";

    serverTimeAcceleration = 2;

    serverNightTimeAcceleration = 0;

    serverTimePersistent = 0;

    disablePersonalLight = 1;

    lightingConfig = 1;

    defaultVisibility = 2200;

    defaultObjectViewDistance = 2200;


    // the mission

    class Missions

    {

    class DayZ

    {

    template="regular.namalsk";

    };

    };

    logFile = "server.log";

    steamport = 12005;

    steamqueryport = 12001;

    adminLogPlayerHitsOnly = 1;

    adminLogPlacement = 1;

    adminLogBuildActions = 1;

    adminLogPlayerList = 1;

    disableBaseDamage = 1;

    disableContainerDamage = 1;

    disableRespawnDialog = 0;


    As you can see, the file calls the "regular.namalsk" map, instead of "DayzOffline.chernarus".

    Hope this helps? :)

  • Profiles folder on nitrado server is "CONFIG" folder. There you will find all your logs if you activate to see player movment, damage and building ect. So if you want to install an Admin tool, then a folder with config file, must end up inside CONFIG folder

  • this is strange if I don't copy the files into the addon folder the server is back again in the boot loop:


    This is what I installed:


    Namlsk_Server1.PNG




    This is my serverDZ.cfg:


    hostname = "xx";

    password = "";

    passwordAdmin = "xx";

    maxPlayers = 4;

    verifySignatures = 2;

    forceSameBuild = 1;

    disableVoN = 0;

    vonCodecQuality = 20;

    disable3rdPerson = 1;

    disableCrosshair = 1;

    guaranteedUpdates = 1;

    loginQueueConcurrentPlayers = 5;

    loginQueueMaxPlayers = 500;

    instanceId = 1;

    storageAutoFix = 1;


    // custom Namalsk edits

    serverTime = "2011/7/7/9/01";

    serverTimeAcceleration = 2;

    serverNightTimeAcceleration = 0;

    serverTimePersistent = 0;

    disablePersonalLight = 1;

    lightingConfig = 0;

    defaultVisibility = 2200;

    defaultObjectViewDistance = 2200;


    // the mission

    class Missions

    {

    class DayZ

    {

    template="regular.namalsk";

    };

    };

    logFile = "server.log";

    steamport = 12005;

    steamqueryport = 12001;

    adminLogPlayerHitsOnly = 0;

    adminLogPlacement = 0;

    adminLogBuildActions = 0;

    adminLogPlayerList = 0;

    disableBaseDamage = 0;

    disableContainerDamage = 0;

    disableRespawnDialog = 0;

  • I cannot figure out what I am missing that this will not work for me. I had already done all the steps, but I tried to run mine in non expert mode, so the game rewrote the cfg file, and I of course loaded into Chernarus. So I wiped everything and started again. Uploaded all the necessary files using FileZilla into the root on Nitrado. Checked expert mode and copied and pasted my cfg from Notepad. What I find odd is that last night when I tried to do this, my Nitrado dashboard actually showed 0/10 players and Current Map: Namalsk. I tried to load it with great anticipation, selected my server, typed in the password, and nothing. No crash, no error messages, nothing. Just sat there with the Server menu up and my character standing behind looking sad and lonely.


    I just spent the last hour going through and doing all of this work again, and same result. Server menu, sad, lonely character, no loading.


    What else can I be missing? I want my character to go be sad, lonely AND cold on Namalsk!

  • Update: I tried launching my server from the DayZ Launcher. It shows Namalsk as the map as well. Either way, it launches, loads about half way, then I get a blue spinning circle in the middle of the screen. I am unable to move my cursor away from the center of the screen without it freaking out and moving back to center. I force closed DayZ and received an error code that may be related to having updated my NVIDIA drivers the other day.

  • Hey Babushka, Did you manage to get it up and running yet? I am a newbie to all this stuff and I managed to get it up and running by watching this video:


    I am currently having an issue however - for the past 4-5 days my server has worked fine. I log in today and it says Warning: You were kicked off the game (verifying PBO failed @NamalskSurvival/addons/ns_dayz.pbo)


    As I said I'm a newbie so I read around a little and saw people mentioning the mod was the wrong version and I notice there was an update yesterday. So I went into filezilla and I removed @NamalskSurvival from my mods, unsubbed then re-subscribed and downloaded the mod again. I then went back into Filezilla and uploaded it back in (removed the space, transferred keys and mission file) and when I restarted the game I could now log in but I had lost all progress and doors wouldn't open.


    I did a restore and am back to being kicked with this error and my geared character is also gone.


    I don't mind completely restarting again but would just like to know what I did wrong here to lose all my progress, and which steps in future I should take to fix this error without losing progress.


    Thank You

  • There was a Namalsk Mod update released yesterday.

    This was the reason you were kicked, because you got the new version in Steam instantly, but your server doesn‘t.

    You have to upload the actualized version to your server again to match.


    you have to update mods by hand every time an update is released.


    No need to restore a backup.