Connection to the host has been lost

Dear forum members,
for some time now we have been creating and maintaining new ways to help game server admins with questions and problems as quickly as possible, e.g. our Guides section and the Nitrado Community Discord.

Therefore, we inform you that the Nitrado Forum will be closed on March 31, 2023. We are consolidating our community support to our Discord channel, which is faster and more efficient. We have also seen incredible growth in our community due to the hard work of our moderators and our bots. We are confident that this move will ensure that we provide the best support possible for our users.

Thank you to all members for your continued use of the forum!

Assistance with all questions concerning your Nitrado service can now be found in these spots:
Community Discord:
Guides section:
Support Wizard:
  • As the title suggest i have that problem when i try to join it, rented and installed the server today, put everything up, went to Sign In and connected it all with the key, but when i connect i get the error in the title.

    I looked a bit on the forum here and found out it could be because of the Germany server that was best suited for me, people had switched to London and apparently that fixed it, so i payed that little fee for switch server location, and set everything up again, but funny enough i still get the same problem.

    Any help on this issue would be greatly appreciated, since it is a server meant for me and my friends for now, but now we can't play even though we paid for it.