Still Unable to Update Server Settings

Nitrado now has an official Discord server to bring communities, friends and other gamers together!
Join the Nitrado Community Discord now and share your experiences and knowledge with others!

Click here to go to the Discord Server!
  • :(
    Want to Get my brothers into the game and kinda ease them into it so i decided to start this server with some easy stuff. No death drops instant blueprint production, plenty of this and that, etc etc

    Bought the server last night, nothing but issues so far.
    None of the settings have saved.
    Stop server

    edit files (both ingame and in note pad. Tried multiple times)
    upload new settings

    Save and start server

    Nothing changes


    IDK what else to do. If push comes to shove i will get a refund and close this server. X(

  • Same here.... just bought a server and ran into the same issue..... nothing sticks even though the settings all look correct as I've changed them from all possible avenues. You load in to the game and it's as it was before you changed the settings. I can download, look at both the files and the dashboard and they are as I've set them, but the game does not reflect those settings.


    Post says problem resolved.... What was the resolution? Or is it a secret.. See several posts but no solution.


    The OP might have found this.... I'm trying it now.... Hope it's the solution.


    Issue #2: Game settings and gameoptions.yaml never "apply." It doesn't matter how much you edit settings through the Nitrado website, or download > edit in Notepad and > reupload, it'll never work and settings will never "stick."

    (Probable) root cause: Nitrado's auto-generated gameoptions.yaml (located in empyrion > Saves > Games > DediGame) is formatted incorrectly. It shows up as literally two very long lines of text and contains curly brackets example: { and }.

    Solution 1a: upload your own gameoptions.yaml with the correct formatting. I've attached my gameoptions.zip for you to work off of. It's 80 lines long. When you do, you have to follow these exact steps:

    1. While the server is running, upload gameoptions.yaml into the empyrion > Saves > Games > DediGame folder.

    2. Hit "Restart server" in the Nitrado panel.

    Solution 1b: If the above doesn't work:

    1. Choose Stop Server via Nitrado website

    2. Choose Start Server via Nitrado website

    3. Upload gameoptions.yaml into the empyrion > Saves > Games > DediGame folder

    4. Choose Restart server via Nitrado website.

    Note: In other words, keep uploading gameoptions.yaml and choose "Restart server" until it works. lol

  • As others have experienced I notice reading through other posts, none of the above mentioned solutions work. Going to try the last thing..... What a headache. Like every option they give you that supposed to do these things easily is just a joke. Then you find you got to rub you nose, slap your face, wipe your butt, and pat your head all at the same time to get it working...... if that even does.

  • LOL.... Looked at the server log. Saw where it was loading the gameoptions.yaml, and stopping on line 78. Rejected.... Just like one piece of contaminated garbage in the entire pile of recyclables. Not sure if that was a setting I changed or one that was copied from another player..... but the issue was using "medium" instead of "normal" for drone attacks. So those new server owners shouldn't look at older problems thinking that is the case for you....... check your file..... even if you have done so before. I was looking at spacing and typos..... not wrong terms. Or check the server log and see if it is even using the file.