Server doesn't display on the list

Become part of a great team that has nothing less as its goal than to be the world's best game server provider. Keep facing new, challenging and exciting tasks at a company that values your opinion.


open positions @ Nitrado
  • I have updated the mods on the mods list and when I start the server it doesn't show up when i search. When I try to direct connect it tells me it took too long. With a few days left of time and almost two days of not being able to get on, I'm pretty frustrated. Is anyone else having this issue with their server for the Exiled Lands?

  • I'm having the same issue. I can't connect to my Conan Server, I don't see it on the list and when I Direct Connect it times out. Addiotionally when I use Steam to check the server it states "the Server is not responding".

    When I attempt to connect to the Server with Filezilla, I get the following message "EAI_NONAME - Neither nodename nor servname provided, or not known".

  • I have updated the mods on the mods list and when I start the server it doesn't show up when i search. When I try to direct connect it tells me it took too long. With a few days left of time and almost two days of not being able to get on, I'm pretty frustrated. Is anyone else having this issue with their server for the Exiled Lands?

    I just had renewed my server, after 3 months of it being up with no issues, and now, i can't even find my server. it isn't like i created a whole new 'pc' version. it was just a renewal. that's $90 wasted, unless i can find a way to get my server back up and running. ANYONE able to help us out? please