Uploading Saves not working?

Dear forum members,
for some time now we have been creating and maintaining new ways to help game server admins with questions and problems as quickly as possible, e.g. our Guides section and the Nitrado Community Discord.

Therefore, we inform you that the Nitrado Forum will be closed on March 31, 2023. We are consolidating our community support to our Discord channel, which is faster and more efficient. We have also seen incredible growth in our community due to the hard work of our moderators and our bots. We are confident that this move will ensure that we provide the best support possible for our users.

Thank you to all members for your continued use of the forum!

Assistance with all questions concerning your Nitrado service can now be found in these spots:
Community Discord: https://discord.gg/nitrado
Guides section: https://server.nitrado.net/guides
Support Wizard: https://support.nitrado.net
  • Hey guys, mr. noob here. So every-time I try to upload a world save to my server, I see a gray gear next to it and it never gives me the option to select that save when starting my server. It used to work, I've been trying this on the experimental version, steam version, regular 17.79 version outside of Steam, I can't figure out why this doesn't work anymore. I've tried new saves, old saves, etc. Even saves that I could load previously don't anymore. I'l providing a screenshot of all of my current saves I've uploaded because I've tried everything I can think of from creating a new save solo or hosting a server within the game itself and I am totally stumped.

    I'm trying to get my server to set up publicly, with mods (or no mods) with modified resource and enemy settings. If there is a way to achieve this, without having to upload the save file, I'd like to know, because this is what I've been able to figure out with the resources available online.

    The "world" zip is the default one that Nitrado generates, the files within it is different, so I don't know if I just need to get certain files into my saves or something, but the 2nd screenshot shows that comparison. Left file is "world" right is "wtf3" named because that is what I am constantly saying at this point lol. Thanks in advance, if I don't get the chance to thank you personally in a timely manner.

    I'm gonna try reinstalling Factorio, non-experimental and try again, but any advice would greatly be appreciated, whenever that reply comes, I'm sure it will help.

    Edit: Trying to load the default "World" save in my game says it's on version 18.38, even though the log files show the server is on 17.79.

  • I'm not entirely sure what the screenshots you put there are showing, but I can tell you how I did it 1 day ago and I will do it alike as soon as 1.0 is on the nitrado servers. managing the saves like that has been working without any issue for me.

    • generate a [savename].zip in your client
    • shut down the server
    • save the existing [savename].zip you want to keep from nitrado servers to a place on your PC
    • delete the [savename].zip existing on the nitrado server
    • wait a bit (~2 mins)
    • upload your new freshly (or already played) [savename].zip to the server
    • wait a bit (~2 mins)
    • boot up the server